summaryrefslogtreecommitdiffstats
path: root/games/dwarffortress/dwarffortress.SlackBuild
blob: 1a305129662c4da3b559f470924cd358d3abab6d (plain)
#!/bin/bash

# Slackware build script for Dwarf Fortress

# Copyright 2021 David Ferrone RI, USA
# All rights reserved.

# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

PRGNAM=dwarffortress
VERSION=${VERSION:-0.47.05}
SRCNAM=df_47_05_linux
SRCDIR=df_linux
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

if [ "$ARCH" = "i586" ]; then
  BITFLAG="32"
elif [ "$ARCH" = "x86_64" ]; then
  BITFLAG=""
else
  BITFLAG=""
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT

cd $TMP
rm -rf $SRCDIR
tar xvf $CWD/$SRCNAM$BITFLAG.tar.bz2
cd $SRCDIR && chown -R root:root .

## Unnecessary in this case. Leave it in case the Toady One ever uses symlinks.
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  -o -perm 511 \) -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;

## Remove two library files that prevent operation, use local libraries instead.
rm libs/libgcc_s.so.1
rm libs/libstdc++.so.6

## These directories will be writeable by the user. Normally mode 700.
find {data,raw,sdl} -type d -exec chmod 755 {} \;

mkdir $PKG/opt
cd ..
mv $SRCDIR $PKG/opt/$PRGNAM

# Strip binaries and libraries -
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr $PKG/usr/doc $PKG/usr/bin
mkdir -p $PKG/usr/share $PKG/usr/share/pixmaps $PKG/usr/share/applications
cat $CWD/dwarffortress.desktop > $PKG/usr/share/applications/dwarffortress.desktop
cat $CWD/dwarffortress.png > $PKG/usr/share/pixmaps/dwarffortress.png

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cd $PKG/opt/$PRGNAM
cp -a README.linux  command\ line.txt  file\ changes.txt readme.txt  \
   release\ notes.txt $PKG/usr/doc/$PRGNAM-$VERSION

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

cat $CWD/dwarffortress > $PKG/usr/bin/dwarffortress
chmod 755 $PKG/usr/bin/dwarffortress

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE