summaryrefslogtreecommitdiffstats
path: root/development/Xdialog/Xdialog.SlackBuild
blob: 5925d3fcbb9a22d896844b91e74fb9b139c8efe8 (plain)
#!/bin/sh

# Slackware build script for Xdialog
# Written by slakmagik <jsun@freeshell.org>
# Released under the WTFPL

PRGNAM=Xdialog
VERSION=${VERSION:-2.3.1}
ARCH=${ARCH:-i486}
BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

NLS=${NLS:-disable}
# I do this so the script has a consistent interface, using 'enable' for both
# - and because passing '--without-gtk2' makes it compile for gtk2 as much as
# '--with; does(!) so you have to pass it nothing if you want gtk1.
if [ "$GTK2" = "enable" ]; then
   GTK2=--with-gtk2
 else
   unset GTK2
fi

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
# NEWS is a symlink to ChangeLog and the latter gets the wrong perms unless I
# exclude links from the tests
find . ! -type l \
  \( \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  -exec chmod 755 {} \; -o \
  \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
  -o -perm 400 \) \) -exec chmod 644 {} \;

CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --datadir=/usr \
  --mandir=/usr/man \
  --$NLS-nls \
  --build=$ARCH-slackware-linux \
  $GTK2

make
make DESTDIR=$PKG install

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

( cd $PKG/usr/man
  find . -type f -exec gzip -9 {} \;
  for i in $(find . -type l); do ln -s $(readlink $i).gz $i.gz; rm $i; done
)

cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cp -a [ABCINR]* $PKG/usr/doc/$PRGNAM-$VERSION

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}