summaryrefslogtreecommitdiffstats
path: root/desktop/razorqt/razorqt.SlackBuild
blob: cec93fd1ba66b8adff4458c68f90709037c1b566 (plain)
#!/bin/sh

# Slackware build script for razorqt

# Copyright 2011, 2012  Robby Workman, Northport, Alabama, USA
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

# Note that if anyone else out there likes this and uses it on a daily basis,
# I'll be more than happy to let you maintain this build script.  I don't
# plan to actually use razorqt (I like xfce), but this looked too useful to
# not have available in Slackware   --rworkman
# Same for me (the only difference is that I use lxde ;p )   --ponce

PRGNAM=razorqt
VERSION=${VERSION:-0.5.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# Fix hardcoded xdg path
patch -p1 < $CWD/patches/dont_hardcode_xdg_path.patch

# Patch for updated libstatgrab (thanks to Debian)
patch -p1 < $CWD/patches/libstatgrab-0.90.patch

# Where our system config (razor and xdg files) resides
RCONFDIR=${RCONFDIR:-etc/razor/xdg}

cmake \
  -DCMAKE_BUILD_TYPE=Release \
  -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  -DCMAKE_INSTALL_PREFIX:PATH="/usr" \
  -DLIB_SUFFIX:STRING="$LIBDIRSUFFIX" \
  -DRAZOR_ETC_XDG_DIRECTORY:PATH="/$RCONFDIR"

make VERBOSE=1
make install DESTDIR=$PKG

find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
  grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/etc/X11/xinit
cat $CWD/xinit/xinitrc.razorqt > $PKG/etc/X11/xinit/xinitrc.razorqt
chmod 0755 $PKG/etc/X11/xinit/xinitrc.razorqt

mkdir -p $PKG/etc/profile.d
sed "s|@RCONFDIR@|/$RCONFDIR|" \
  $CWD/profile.d/razorqt.sh > $PKG/etc/profile.d/razorqt.sh
sed "s|@RCONFDIR@|/$RCONFDIR|" \
  $CWD/profile.d/razorqt.csh > $PKG/etc/profile.d/razorqt.csh
chmod 0755 $PKG/etc/profile.d/*

# Don't clobber existing config files
for i in desktop razor session windowmanagers razor-panel/panel; do
  mv $PKG/$RCONFDIR/razor/$i.conf $PKG/$RCONFDIR/razor/$i.conf.new
done
# Add missing section entry in razor.conf, to avoid complains
# from razor-confupdate python script...
sed -i '/^theme/i [General]' $PKG/$RCONFDIR/razor/razor.conf.new || exit 1
# ...beside the fact that it looks in the wrong path...
sed -i "s|\.razor|.config/razor|" $PKG/usr/share/razor/razor-confupdate/* || exit 1

# There's a small issue: seems like default configs are not created when
# you launch razor the first time: copy them from their global dir if
# ~/.config/razor doesn't exist
sed -i "s|^$|if [ ! -d ~/.config/razor ]; then mkdir -p ~/.config ; cp -a /$RCONFDIR/razor ~/.config/razor ; fi|" $PKG/usr/bin/startrazor

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
sed "s|@RCONFDIR@|$RCONFDIR|" $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}