summaryrefslogtreecommitdiffstats
path: root/desktop/kfaenza-icon-theme/kfaenza-icon-theme.SlackBuild
blob: 0703cf58bf381339c563d566c5281bf7f2cc94ca (plain)
#!/bin/bash

# Slackware Package Build Script for KFaenza icon theme
# Benjamin Trigona-Harany
# 2022 Klaatu <klaatu@member.fsf.org>

# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:

# 1. Redistributions of script must retain the above copyright notice,
#    this list of conditions and the following disclaimer.

# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
# EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
# PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
# LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM="kfaenza-icon-theme"
VERSION=${VERSION:-0.8.9_19}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

REL=${REL:-fc35}
RELVER=$(echo $VERSION | tr '_' '-')
ARCH=noarch ## hardcode ARCH

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -fr $TMP/${PRGNAM}-${VERSION} $PKG

mkdir -p $TMP $PKG $OUTPUT $TMP/${PRGNAM}-${VERSION}
cd $TMP/${PRGNAM}-${VERSION}

rpm2archive $CWD/${PRGNAM}-${RELVER}.$REL.$ARCH.rpm
mv $CWD/${PRGNAM}-${RELVER}.$REL.$ARCH.rpm.tgz \
   $TMP/${PRGNAM}-${VERSION}

tar -xvf ${PRGNAM}-${RELVER}.$REL.$ARCH.rpm.tgz --strip-components 1

chown -R root.root .
find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;

# following is from the KFaenza INSTALL script
iconname="start-here-slackware"
cd ./usr/share/icons/KFaenza/places/scalable/ && ln -sf ./$iconname.svg distributor-logo.svg

cd $TMP/${PRGNAM}-${VERSION}

for size in 256 128 64 48 32 22 16; do
    cd ./usr/share/icons/KFaenza/places/$size/
    ln -sf ./$iconname.png distributor-logo.png
    cd $TMP/${PRGNAM}-${VERSION}
done

mkdir -p $PKG
cp -a ./usr $PKG

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
# 20200407 bkw: makepkg's symlink search and doinst.sh creation doesn't
# scale well. This makes the build complete much faster, and create an
# identical doinst.sh.
find . -type l \
  -printf '( cd %h ; rm -rf %f )\n( cd %h ; ln -sf %l %f )\n' -delete | \
  sed 's,cd \./,cd ,' >> $PKG/install/doinst.sh

/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE