summaryrefslogtreecommitdiffstats
path: root/desktop/google-gadgets-for-linux/google-gadgets-for-linux.SlackBuild
blob: ead159ba65fffe7473ca9cc39f5d820c6fb3586f (plain)
#!/bin/sh
# Slackbuild for google-gadgets-for-linux
# Written by JK Wood <joshuakwood@gmail.com>

# Slackbuild is released under the Dog-on-Fire License:
# If use of this script causes your dog to catch on fire,
# you agree to send me five dollars.  Or a picture
# of the dog on fire.
# Otherwise, you're on your own.  I've tested the script
# on my own computer, and it hasn't broken anything.
# So if it does it on your computer, that falls in
# the realm of "Not my problem."
#
# Of course, if you'll send a bug report to the above
# email address, I may be able to see what you did
# wrong and prevent it from happening in the future.
# In which case, I may just send YOU five dollars.

# Modified by SlackBuilds.org

PRGNAM=google-gadgets-for-linux
VERSION=0.11.0
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
fi

set -eu

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find . \
\( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# These are needed to properly link the seamonkey stuff
EXTRA_INCLUDES="\
  -I/usr/include/seamonkey/dom \
  -I/usr/include/seamonkey/content \
  -I/usr/include/seamonkey/widget \
  -I/usr/include/seamonkey/xpconnect"

GTKMOZEMBED_CFLAGS="$(pkg-config --cflags seamonkey-gtkmozembed)" \
GTKMOZEMBED_LIBS="$(pkg-config --libs seamonkey-gtkmozembed)" \
LIBMOZJS_CFLAGS="$(pkg-config --cflags seamonkey-js)" \
LIBMOZJS_LIBS="$(pkg-config --libs seamonkey-js)" \
CFLAGS="$SLKCFLAGS $EXTRA_INCLUDES" \
CXXFLAGS="$SLKCFLAGS $EXTRA_INCLUDES" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib$LIBDIRSUFFIX \
  --sysconfdir=/etc \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --mandir=/usr/man \
  --disable-static \
  --with-browser-plugins-dir=/usr/lib$LIBDIRSUFFIX/mozilla/plugins \
  --build=$ARCH-slackware-linux

make
make install-strip DESTDIR=$PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS \
  $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}