summaryrefslogtreecommitdiffstats
path: root/desktop/Tela-icon-theme/Tela-icon-theme.SlackBuild
blob: a3e1002c585bc7f9bb927ddaa349c7ee2e15b896 (plain)
#!/bin/bash

# Slackware build script for Tela-icon-theme

# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM="Tela-icon-theme"
SRCNAM="tela-icon-theme"
SRCVER=${SRCVER:-2022-02-21}
VERSION=${VERSION:-2022_02_21}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

ARCH=noarch

if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$SRCVER
tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
cd $PRGNAM-$SRCVER

chown -R root:root .

# This slackbuild installs the standard color variant by default
# Other color variants are available
if [ "${BLACK:-no}" == yes ] ; then BLACK=black ; fi
if [ "${BLUE:-no}" == yes ] ; then BLUE=blue ; fi
if [ "${BROWN:-no}" == yes ] ; then BROWN=brown ; fi
if [ "${GREEN:-no}" == yes ] ; then GREEN=green ; fi
if [ "${GREY:-no}" == yes ] ; then GREY=grey ; fi
if [ "${ORANGE:-no}" == yes ] ; then ORANGE=orange ; fi
if [ "${PINK:-no}" == yes ] ; then PINK=pink ; fi
if [ "${PURPLE:-no}" == yes ] ; then PURPLE=purple ; fi
if [ "${RED:-no}" == yes ] ; then RED=red ; fi
if [ "${YELLOW:-no}" == yes ] ; then YELLOW=yellow ; fi
if [ "${MANJARO:-no}" == yes ] ; then MANJARO=manjaro ; fi
if [ "${UBUNTU:-no}" == yes ] ; then UBUNTU=ubuntu ; fi

# I cannot install all of the color variants at once. To put it in another way:
# This slackbuild will not install with the following command:
# ./install.sh -a -d $PKG/usr/share/icons
# Instead, you will have to select additional color variants by passing variables to the script
mkdir -p $PKG/usr/share/icons
./install.sh standard $BLACK $BLUE $BROWN $GREEN $GREY $ORANGE $PINK $PURPLE $RED $YELLOW \
	$MANJARO $UBUNTU -d $PKG/usr/share/icons

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp AUTHORS COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
find . -type l \
  -printf '( cd %h ; rm -rf %f )\n( cd %h ; ln -sf %l %f )\n' -delete | \
  sed 's,cd \./,cd ,' >> $PKG/install/doinst.sh
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE