summaryrefslogtreecommitdiffstats
path: root/audio/xmms2/xmms2.SlackBuild
blob: 3dc928e7b54a72304f5ce7f2bc07059d334d71db (plain)
#!/bin/sh

# Slackware build script for xmms2

# Written by Kyle Guinn <elyk03@gmail.com>
# Updated by Rainer Wittmaack <ningo@gmx.net>
# Updated by Andrew Brouwers, abrouwers at gmail d0t com (13.0, 64-bit)

PRGNAM=xmms2
VERSION="0.6DrMattDestruction"
ARCH=${ARCH:-i486}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

# Sorry waf, you have no right outside of $TMP
# NOTE: this is fixed in master with a configure option (--without-ldconfig)
sed -i 's#/sbin/ldconfig#/bin/true#' wscript

# Don't be fooled by --with-libdir (fixed upstream, too)
patch -Np1 -i $CWD/0.6_fix_libdir.diff

# Fix compile for ruby 1.9
# patch -Np1 -i $CWD/xmms2-ruby-1.9.patch

export CCFLAGS="$SLKCFLAGS"
export CXXFLAGS="$SLKCFLAGS"

./waf --prefix=/usr \
  --with-libdir=/usr/lib${LIBDIRSUFFIX} \
  --with-pkgconfigdir=/usr/lib${LIBDIRSUFFIX}/pkgconfig \
  --with-mandir=/usr/man \
  -p configure

./waf build
./waf install --destdir=$PKG

( cd $PKG
  find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null || true
  find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
    xargs strip --strip-unneeded 2> /dev/null || true
)

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a AUTHORS COPYING* INSTALL README TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}