summaryrefslogtreecommitdiffstats
path: root/audio/listener/listener.SlackBuild
blob: c38c1859c973c6b7ae9a4575630c4549735560fc (plain)
#!/bin/bash
#
# Slackware build script for listener.
#
# Distributed under the beerware licence:
#
# "THE BEER-WARE LICENSE" (Revision 42):
# pwcazenave <at> gmail <dot> com wrote this file. As long as you retain this
# notice you can do whatever you want with this stuff. If we meet some day,
# and you think this stuff is worth it, you can buy me a beer in return
# Pierre Cazenave
#
# Created 07/08/2008
# Updated for Slackware64 28/05/2009
# Updated to version 2.0.1 09/10/2011
#

PRGNAM=listener
VERSION=2.0.1
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i486 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i486" ]; then
  SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
	   | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

# make the destination directories for the Makefile, otherwise it keels over.
mkdir -p $PKG/{usr/bin,etc}

# fix Makefile so install path to /usr/bin, not /bin
sed -i 's@(INSTALL_PREFIX)/bin@(INSTALL_PREFIX)/usr/bin@g' Makefile

# fix listener.h hardcoded config file path
sed -i 's@/usr/local/etc/listener.conf@/etc/listener.conf@' listener.h

# fix the documentation reference to the config file too
sed -i 's@/usr/local/etc/listener.conf@/etc/listener.conf@' manual.html

CFLAGS="$SLKCFLAGS" \
make install INSTALL_PREFIX=$PKG

find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
( cp -a license.txt manual.html $PKG/usr/doc/$PRGNAM-$VERSION )
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;

# Don't clobber existing .conf files in /etc
mv $PKG/etc/listener.conf $PKG/etc/listener.conf.new

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}