summaryrefslogtreecommitdiffstats
path: root/audio/clam/clam.SlackBuild
blob: 01a60c8166b958b3139acca7c39e70869d9604d9 (plain)
#!/bin/bash

# Slackware build script for clam

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=clam
VERSION=${VERSION:-r15456}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

SRCNAM=CLAM

if [ -z "$ARCH" ]; then
  case "$( uname -m )" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$( uname -m ) ;;
  esac
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG/usr $OUTPUT # NB: $PKG/usr must exist, not just $PKG
cd $TMP
rm -rf $SRCNAM-$VERSION
tar xvf $CWD/$SRCNAM-$VERSION.tar.?z*
cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
 \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
 -exec chmod 755 {} \; -o \
 \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
 -exec chmod 644 {} \;

# scons failing to link libvorbis/libogg test progs.
patch -p1 < $CWD/scons_sucks.diff

# An include is called incorrectly
patch -p1 < $CWD/wrong_include.patch

# Annoying scons script has hard-coded self.lib  = self.prefix + '/lib'
if [ "$LIBDIRSUFFIX" != "" ]; then
  sed -i "s,/lib\>,/lib$LIBDIRSUFFIX," scons/libs/clam_build_helpers.py
fi

# 20200118 bkw: as part of its configure process, scons compiles and runs
# a sample jack program. With jack2, if jackd isn't already running,
# this creates root-owned files in /dev/shm/jack_db that don't get
# deleted afterwards.  No problem, except that the next time the user
# tries to start jackd, it will be unable to write to jack_db. Which
# makes jackd segfault. Even if it didn't segfault, it would presumably
# still not start (with an error message). The workaround is to NOT
# compile/run the jack test program (just assume the test succeeds).
# Whew. The explanation is *way* more complex than the fix.
sed -i '/CheckLibrarySample.*jack_test_code/,+1d' \
        scons/libs/clam_dependent_libs_checks.py

CCFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
	scons configure \
	with_fftw3=yes \
	release=yes \
	prefix=/usr \
	prefix_for_packaging=$PKG/usr

scons $MAKEFLAGS
scons install
strip $PKG/usr/lib$LIBDIRSUFFIX/*.so.*.*

mv $PKG/usr/share/man $PKG/usr/man
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CHANGES examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}