summaryrefslogtreecommitdiffstats
path: root/audio/TiMidity++/TiMidity++.SlackBuild
blob: 5c7f4be037f136abf66ba3bfcfaa6c9c66e4d6d7 (plain)
#!/bin/bash

# Slackware build script for TiMidity++

# Copyright 2010-2018 Kyle Guinn <elyk03@gmail.com>
# Changes for Slackware 12.1 by Richard Hoyle <hoyle.richard@gmail.com>
# Modified by Michiel van Wessem. <michiel.van.wessem@gmail.com>
# Modified by Yair Kalvariski. <cesium2@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
#
# 1. Redistributions of this script must retain the above copyright
#    notice, this list of conditions and the following disclaimer.
#
#  THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
#  WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
#  MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.  IN NO
#  EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
#  SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
#  PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
#  OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
#  WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
#  OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
#  ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

cd $(dirname $0) ; CWD=$(pwd)

PRGNAM=TiMidity++
VERSION=${VERSION:-2.15.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}

if [ -z "$ARCH" ]; then
  case "$(uname -m)" in
    i?86) ARCH=i586 ;;
    arm*) ARCH=arm ;;
       *) ARCH=$(uname -m) ;;
  esac
fi

# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
# the name of the created package would be, and then exit. This information
# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  exit 0
fi

TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM-$VERSION
OUTPUT=${OUTPUT:-/tmp}

DOCS="AUTHORS COPYING ChangeLog* INSTALL* NEWS README* TODO doc/C/README* doc/C/FAQ doc/C/CHANGES.02i"

# These should be supported in the full Slackware install.
ENABLE_AUDIO="alsa,oss,esd,ao,vorbis,flac"
# Auto-detect these optional dependencies.
if pkg-config --exists portaudio-2.0; then
  ENABLE_AUDIO="$ENABLE_AUDIO,portaudio"
fi
if pkg-config --exists jack; then
  ENABLE_AUDIO="$ENABLE_AUDIO,jack"
fi
if pkg-config --exists speex; then
  ENABLE_AUDIO="$ENABLE_AUDIO,speex"
fi

if [ "$ARCH" = "i586" ]; then
  SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
  SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
  SLKCFLAGS="-O2 -fPIC"
  LIBDIRSUFFIX="64"
else
  SLKCFLAGS="-O2"
  LIBDIRSUFFIX=""
fi

set -e

rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
TARBALL=$CWD/$PRGNAM-$VERSION.tar.xz
if [ ! -e $TARBALL ]; then
  TARBALL=$CWD/TiMidity%2B%2B-$VERSION.tar.xz
fi
tar xvf $TARBALL
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go-w,a+rX-st .

# Patches:
# Remove liboggflac autoconf clutter, as it has been merged into flac
# since FLAC-1.1.3
for patch in $CWD/patches/* ; do
  patch -p1 < $patch
done

# Regenerate files for automake/autoconf.
# Required for --docdir
autoreconf -vif

EXTRACFLAGS="$SLKCFLAGS" \
./configure \
  --prefix=/usr \
  --libdir=/usr/lib${LIBDIRSUFFIX} \
  --sysconfdir=/etc \
  --localstatedir=/var \
  --mandir=/usr/man \
  --infodir=/usr/info \
  --docdir=/usr/doc/$PRGNAM-$VERSION \
  --disable-dependency-tracking \
  --enable-audio=${ENABLE_AUDIO} \
  --enable-xdnd \
  --enable-ncurses=dynamic \
  --enable-slang=dynamic \
  --enable-motif=dynamic \
  --enable-tcltk=dynamic \
  --enable-emacs=dynamic \
  --enable-vt100=dynamic \
  --enable-xaw=dynamic \
  --enable-xskin=dynamic \
  --enable-gtk=dynamic \
  --enable-server=dynamic \
  --enable-alsaseq=dynamic \
  --enable-network \
  --enable-spectrogram \
  --with-default-path=/etc/timidity \
  --with-module-dir=/usr/lib${LIBDIRSUFFIX}/timidity \
  --with-xaw-resource-prefix=/etc/X11 \
  --build=$ARCH-slackware-linux

make
make install-strip DESTDIR=$PKG

find $PKG/usr/man -type f -exec gzip -9 {} +

# Create a default timidity.cfg
# TiMidity++ will complain if this file is missing.
mkdir -p $PKG/etc/timidity
cat $CWD/timidity.cfg > $PKG/etc/timidity/timidity.cfg.new

# Copy the startup script
mkdir -p $PKG/etc/rc.d
cat $CWD/rc.timidity > $PKG/etc/rc.d/rc.timidity.new

mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cat $CWD/doinst.sh > $PKG/install/doinst.sh

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE