summaryrefslogtreecommitdiffstats
path: root/accessibility/wgetpaste/wgetpaste.SlackBuild
blob: ce6498125d9f7d9014ad51b1a40e4a65f15de51e (plain)
#!/bin/sh

# Slackware build script for wgetpaste

# Written by B. Watson (yalhcru@gmail.com)

# Licensed under the WTFPL. See http://sam.zoy.org/wtfpl/ for details.

PRGNAM=wgetpaste
VERSION=${VERSION:-2.20}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}

ARCH=noarch

ZSHDIR=/usr/share/zsh/site-functions

CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}

set -e

rm -rf $PKG
mkdir -p $TMP $OUTPUT $PKG/usr/bin $PKG/etc/$PRGNAM.d $PKG/usr/man/man1 $PKG/$ZSHDIR
cd $TMP
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION

# The default pastebin is gists, which isn't actually working today. Never
# used it myself so I dunno if it's a temporary thing or a bug in wgetpaste
# or what. Older wgetpaste defaults to dpaste, which still works fine, so
# let's make that the default.
patch -p1 < $CWD/dpaste_default.diff

# x11-misc/xclip => xclip
# 'emerge --info' => wgetpaste_info
patch -p1 < $CWD/no_gentooisms.diff

install -groot -oroot -m0755 $PRGNAM $PKG/usr/bin
install -groot -oroot -m0644 _$PRGNAM $PKG/$ZSHDIR
install -groot -oroot -m0644 $CWD/$PRGNAM.example $PKG/etc/$PRGNAM.conf.sample
install -groot -oroot -m0755 $CWD/${PRGNAM}_info $PKG/usr/bin

# Add zlin.dk service, operated by the wgetpaste author
install -groot -oroot -m0644 $CWD/zlin.conf $PKG/etc/$PRGNAM.d/

# Man page made by help2man and edited slightly
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz

mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc

cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}