summaryrefslogtreecommitdiffstats
path: root/system/wiimms-iso-tools
diff options
context:
space:
mode:
Diffstat (limited to 'system/wiimms-iso-tools')
-rw-r--r--system/wiimms-iso-tools/README2
-rw-r--r--system/wiimms-iso-tools/cflags.diff122
-rw-r--r--system/wiimms-iso-tools/wiimms-iso-tools.SlackBuild55
-rw-r--r--system/wiimms-iso-tools/wiimms-iso-tools.info10
4 files changed, 38 insertions, 151 deletions
diff --git a/system/wiimms-iso-tools/README b/system/wiimms-iso-tools/README
index c1bc7b1d28..d2ecdeae90 100644
--- a/system/wiimms-iso-tools/README
+++ b/system/wiimms-iso-tools/README
@@ -1,3 +1,5 @@
+wiimms-iso-tools (command line ISO and WBFS tools)
+
Wiimms ISO Tools is a set of command line tools to manipulate Wii and
GameCube ISO images and WBFS containers. The toolset consists of the
following tools:
diff --git a/system/wiimms-iso-tools/cflags.diff b/system/wiimms-iso-tools/cflags.diff
deleted file mode 100644
index 0e483f6ecd..0000000000
--- a/system/wiimms-iso-tools/cflags.diff
+++ /dev/null
@@ -1,122 +0,0 @@
---- Makefile.orig 2019-12-22 07:58:45.850503487 -0800
-+++ Makefile 2019-12-22 08:17:35.475369649 -0800
-@@ -112,8 +112,8 @@
- # compiler settings
-
- PRE ?=
--CC = $(PRE)gcc
--CPP = $(PRE)g++
-+CC ?= $(PRE)gcc
-+CXX ?= $(PRE)g++
- STRIP = $(PRE)strip
-
- #-------------------------------------------------------------------------------
-@@ -243,7 +243,8 @@
- DCLIB_DIR := ./dclib
- DIR_LIST += $(DCLIB_DIR)
- VPATH += $(DCLIB_DIR)
--CFLAGS += -I$(DCLIB_DIR)
-+CFLAGS ?= -O3 -funroll-loops
-+DEF_FLAGS := -I$(DCLIB_DIR)
-
- # other objects
- WIT_O := lib-std.o lib-file.o lib-sf.o \
-@@ -297,17 +298,17 @@
- DEFINES1 += -D_LZMA_PROB32=1 # LZMA option
- DEFINES = $(strip $(DEFINES1) $(MODE) $(XDEF))
-
--CFLAGS += -fomit-frame-pointer -fno-strict-aliasing -funroll-loops
--CFLAGS += -Wall -Wno-parentheses -Wno-unused-function
--#CFLAGS += -O3 -Isrc/libwbfs -Isrc/lzma -Isrc -I$(UI) -I. -Iwork
--CFLAGS += -O3 -Isrc/libwbfs -Isrc -I$(UI) -I. -Iwork
-+DEF_FLAGS += -fomit-frame-pointer -fno-strict-aliasing
-+DEF_FLAGS += -Wall -Wno-parentheses -Wno-unused-function
-+#DEF_FLAGS += -Isrc/libwbfs -Isrc/lzma -Isrc -I$(UI) -I. -Iwork
-+DEF_FLAGS += -Isrc/libwbfs -Isrc -I$(UI) -I. -Iwork
- ifeq ($(SYSTEM),cygwin)
-- CFLAGS += -Wno-format-truncation
-+ DEF_FLAGS += -Wno-format-truncation
- else ifeq ($(SYSTEM),mac)
-- CFLAGS += -I/usr/local/include
-+ DEF_FLAGS += -I/usr/local/include
- endif
--CFLAGS += $(XFLAGS)
--CFLAGS := $(strip $(CFLAGS))
-+DEF_FLAGS += $(XFLAGS)
-+DEF_FLAGS := $(strip $(DEF_FLAGS))
-
- DEPFLAGS += -MMD
-
-@@ -371,7 +372,7 @@
-
- $(ALL_TOOLS_X): %: %.o $(ALL_OBJECTS) $(TOBJ_ALL) Makefile | $(HELPER_TOOLS)
- @printf "$(LOGFORMAT_TOOL)" tool "$@" "$(MODE) $(TOPT_$@) $(TOBJ_$@)"
-- @$(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEFINES) $(LDFLAGS) $@.o \
- $(ALL_OBJECTS) $(TOBJ_$@) $(LIBS) $(TOPT_$@) -o $@
- @if test -f $@.exe; then $(STRIP) $@.exe; else $(STRIP) $@; fi
-
-@@ -384,7 +385,7 @@
-
- $(HELPER_TOOLS): %: %.o $(ALL_OBJECTS) $(UI_TABS) Makefile
- @printf "$(LOGFORMAT_TOOL)" helper "$@ $(TOBJ_$@)" "$(MODE)"
-- @$(CC) $(CFLAGS) $(DEFINES) $(LDFLAGS) $@.o \
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEFINES) $(LDFLAGS) $@.o \
- $(ALL_OBJECTS) $(TOBJ_$@) $(LIBS) -o $@
-
- #--------------------------
-@@ -397,19 +398,19 @@
-
- $(UI_OBJECTS): %.o: %.c ui-%.c ui-%.h version.h Makefile
- @printf "$(LOGFORMAT_CC)" +object "$@" "$(MODE)"
-- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-
- #--------------------------
-
- $(C_OBJECTS): %.o: %.c version.h Makefile $(TEXT_FILES)
- @printf "$(LOGFORMAT_CC)" object "$@" "$(MODE)"
-- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-
- #--------------------------
-
- $(ASM_OBJECTS): %.o: %.S Makefile
- @printf "$(LOGFORMAT_CC)" asm "$@" "$(MODE)"
-- @$(CC) $(CFLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEPFLAGS) $(DEFINES) -c $< -o $@
-
- #--------------------------
-
-@@ -442,11 +443,11 @@
-
- $(LIBBZ2_OBJ): %.o: %.c Makefile
- @printf "$(LOGFORMAT_CC)" object "$(subst src/libbz2/,,$@)" "$(MODE) [libbz2]"
-- @$(CC) $(CFLAGS) $(DEPFLAGS) $(BZIP2_FLAGS) $(DEFINES) -c $< -o $@
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEPFLAGS) $(BZIP2_FLAGS) $(DEFINES) -c $< -o $@
-
- $(LZMA_OBJ): %.o: %.c Makefile
- @printf "$(LOGFORMAT_CC)" object "$(subst src/lzma/,,$@)" "$(MODE) [lzma]"
-- @$(CC) $(CFLAGS) $(DEPFLAGS) $(LZMA_FLAGS) $(DEFINES) -c $< -o $@
-+ @$(CC) $(CFLAGS) $(DEF_FLAGS) $(DEPFLAGS) $(LZMA_FLAGS) $(DEFINES) -c $< -o $@
-
- #
- ###############################################################################
-@@ -658,6 +659,8 @@
- @echo ""
- @echo "CFLAGS: $(CFLAGS)"
- @echo ""
-+ @echo "DEF_FLAGS: $(DEF_FLAGS)"
-+ @echo ""
- @echo "LDFLAGS: $(LDFLAGS)"
- @echo ""
- @echo "LIBS: $(LIBS)"
-@@ -1005,7 +1008,7 @@
- @echo " make old enable '-DOLD_FEATURES'"
- @echo " make wait enable '-DWAIT'"
- @echo " make testtrace enable '-DTESTTRACE'"
-- @echo " make flags print DEFINES, CFLAGS and LDFLAGS"
-+ @echo " make flags print DEFINES, CFLAGS, DEF_FLAGS and LDFLAGS"
- @echo ""
- @echo " make doc generate doc files from their templates"
- @echo " make distrib make all & build $(DISTRIB_PATH)"
diff --git a/system/wiimms-iso-tools/wiimms-iso-tools.SlackBuild b/system/wiimms-iso-tools/wiimms-iso-tools.SlackBuild
index 58df4b17f5..644e8c7071 100644
--- a/system/wiimms-iso-tools/wiimms-iso-tools.SlackBuild
+++ b/system/wiimms-iso-tools/wiimms-iso-tools.SlackBuild
@@ -4,6 +4,7 @@
#
# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
# Copyright 2015, 2018-2019 Hunter Sezen California, USA
+# Copyright 2024 B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,10 +26,15 @@
# 20220209 bkw: Modified by SlackBuilds.org: fix build on 15.0.
+# 20240902 bkw:
+# - new maintainer.
+# - update for v3.05a.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=wiimms-iso-tools
-VERSION=${VERSION:-3.02a}
+VERSION=${VERSION:-3.05a}
+COMMIT=${COMMIT:-fc1c0b840cb3ac41ca6e4f1d5e16da12b47eab58}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,9 +47,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,16 +58,12 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
else
SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
fi
set -eu
@@ -72,35 +71,43 @@ set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM.source-$VERSION
-tar xvf $CWD/$PRGNAM.source-$VERSION.txz
-cd $PRGNAM.source-$VERSION
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} + -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} +
+
+cd project
-patch -p0 < $CWD/cflags.diff
+# 20240902 bkw: do not rebuild everything on 'make install', after
+# 'make' has been run.
+sed -i '/^install:/s,: *all,:,' Makefile
# 20220209 bkw: I need to see the compile/link commands!
sed -i 's,@\$(CC),$(CC),g' Makefile
# 20220209 bkw: overriding in the environment or as make args just
# wasn't working, so I nuked it from orbit. It's the only way to be sure.
-SLKCFLAGS+=" -Wl,--allow-multiple-definition -fcommon"
sed -i "s|-O3|$SLKCFLAGS|" Makefile test-libwbfs/Makefile
-make
-
-# Fix the install directory
-sed -i "s|/usr/local|$PKG/usr|" templates.sed
+# 20240902 bkw: big pain in my ass: no DESTDIR support, and the
+# scripts templates.sed install.sh get the install paths baked-in
+# when I run 'make'. So using a different INSTALL_PATH and INSTBIN in
+# the 'make install' command has no effect, and the executables end up
+# with the /tmp/SBo/... path baked into them. This solution works and
+# isn't too hard to understand:
+make INSTALL_PATH=/usr INSTBIN=/usr/bin
+make -B templates.sed install.sh INSTALL_PATH=$PKG/usr INSTBIN=$PKG/usr/bin
+# 20240902 bkw: binaries already stripped.
make install
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" |
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20240902 bkw: replace hard links with symlinks.
+for i in cat dump; do
+ rm -f $PKG/usr/bin/wdf-$i
+ ln -s wdf $PKG/usr/bin/wdf-$i
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a gpl-2.0.txt $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/system/wiimms-iso-tools/wiimms-iso-tools.info b/system/wiimms-iso-tools/wiimms-iso-tools.info
index c15948fdb0..ccbca1fd6f 100644
--- a/system/wiimms-iso-tools/wiimms-iso-tools.info
+++ b/system/wiimms-iso-tools/wiimms-iso-tools.info
@@ -1,10 +1,10 @@
PRGNAM="wiimms-iso-tools"
-VERSION="3.02a"
+VERSION="3.05a"
HOMEPAGE="https://wit.wiimm.de/"
-DOWNLOAD="https://download.wiimm.de/source/wiimms-iso-tools/wiimms-iso-tools.source-3.02a.txz"
-MD5SUM="a49c0fe7e5cf7fff7dd13fbdacb946eb"
+DOWNLOAD="https://github.com/Wiimm/wiimms-iso-tools/archive/fc1c0b840cb3ac41ca6e4f1d5e16da12b47eab58/wiimms-iso-tools-fc1c0b840cb3ac41ca6e4f1d5e16da12b47eab58.tar.gz"
+MD5SUM="ed9d941138340f4e997209c76f5732f8"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Hunter Sezen"
-EMAIL="orbea@riseup.net"
+MAINTAINER="B. Watson"
+EMAIL="urchlay@slackware.uk"