summaryrefslogtreecommitdiffstats
path: root/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/virtualbox-kernel/virtualbox-kernel.SlackBuild')
-rw-r--r--system/virtualbox-kernel/virtualbox-kernel.SlackBuild21
1 files changed, 3 insertions, 18 deletions
diff --git a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
index d879686802..f8a06985a2 100644
--- a/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
+++ b/system/virtualbox-kernel/virtualbox-kernel.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for virtualbox-kernel
-# Copyright 2008-2019 Heinz Wiesinger, Amsterdam, The Netherlands
+# Copyright 2008-2020 Heinz Wiesinger, Amsterdam, The Netherlands
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +25,8 @@
# Modified by SlackBuilds.org
PRGNAM=virtualbox-kernel
-VERSION=${VERSION:-5.0.40}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-6.1.10}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
KERNEL=${KERNEL:-$(uname -r)}
@@ -70,27 +70,12 @@ if ! [ "${HARDENING:-yes}" = "yes" ]; then
{vboxdrv,vboxnetadp,vboxnetflt,vboxpci}/Makefile
fi
-KERNEL_LOCALVERSION=$(zgrep "CONFIG_LOCALVERSION=" /proc/config.gz | cut -d '"' -f 2)
-if [ -z "$KERNEL_LOCALVERSION" ]; then
- KERNEL_MINOR=$(echo $KERNEL | cut -d "." -f 2)
- KERNEL_PATCH=$(echo $KERNEL | cut -d "." -f 3)
-else
- KERNEL_MINOR=$(echo $KERNEL | sed "s|$KERNEL_LOCALVERSION||" | cut -d "." -f 2)
- KERNEL_PATCH=$(echo $KERNEL | sed "s|$KERNEL_LOCALVERSION||" | cut -d "." -f 3)
-fi
-
-# Work around API break introduced in kernel 4.4.168
-if [ "$KERNEL_MINOR" = 4 -a "$KERNEL_PATCH" -ge 168 ]; then
- sed -i "s|KERNEL_VERSION(4, 9, 0)|KERNEL_VERSION(4, 4, 168)|" vboxdrv/r0drv/linux/memobj-r0drv-linux.c
-fi
-
make KERN_DIR=${KERNELPATH}
mkdir -p $PKG/lib/modules/$KERNEL/misc
install -m 0644 vboxdrv.ko $PKG/lib/modules/$KERNEL/misc/
install -m 0644 vboxnetflt.ko $PKG/lib/modules/$KERNEL/misc/
install -m 0644 vboxnetadp.ko $PKG/lib/modules/$KERNEL/misc/
-install -m 0644 vboxpci.ko $PKG/lib/modules/$KERNEL/misc/
mkdir -p $PKG/usr/doc/$PRGNAM-$PKG_VERS
cat $CWD/COPYING > $PKG/usr/doc/$PRGNAM-$PKG_VERS/COPYING