summaryrefslogtreecommitdiffstats
path: root/system/upx/upx.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/upx/upx.SlackBuild')
-rw-r--r--system/upx/upx.SlackBuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/system/upx/upx.SlackBuild b/system/upx/upx.SlackBuild
index 2f139e743f..61c2d5a537 100644
--- a/system/upx/upx.SlackBuild
+++ b/system/upx/upx.SlackBuild
@@ -55,6 +55,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+sed -i "s|^CXXFLAGS_WERROR.*|CXXFLAGS_WERROR =|" src/Makefile
+
# Extract LZMA SDK to a proper place for use at build-time
mkdir -p $TMP/lzma465
tar xvf $CWD/lzma465.tar.bz2 -C $TMP/lzma465