summaryrefslogtreecommitdiffstats
path: root/system/univga-font/buildfix.diff
diff options
context:
space:
mode:
Diffstat (limited to 'system/univga-font/buildfix.diff')
-rw-r--r--system/univga-font/buildfix.diff24
1 files changed, 24 insertions, 0 deletions
diff --git a/system/univga-font/buildfix.diff b/system/univga-font/buildfix.diff
new file mode 100644
index 0000000000..2a4bacf1d4
--- /dev/null
+++ b/system/univga-font/buildfix.diff
@@ -0,0 +1,24 @@
+diff -wNaur uni_vga/Makefile uni_vga.patched/Makefile
+--- uni_vga/Makefile 2000-07-13 00:00:12.000000000 -0400
++++ uni_vga.patched/Makefile 2014-05-26 14:35:42.000000000 -0400
+@@ -15,7 +15,7 @@
+ SIZE= 16
+
+ %-$(FACE)-8x$(SIZE).psf: u_$(FACE)$(SIZE).bdf %.sfm
+- $(BDF2PSF) -s $*.sfm $< | psfaddtable -c $*.sfm -o $@ -
++ $(BDF2PSF) -s $*.sfm $< | psfaddtable - $*.sfm $@
+
+ .PHONY: default allfonts
+
+diff -wNaur uni_vga/bdf2psf.pl uni_vga.patched/bdf2psf.pl
+--- uni_vga/bdf2psf.pl 2000-07-20 03:28:10.000000000 -0400
++++ uni_vga.patched/bdf2psf.pl 2014-05-26 14:34:48.000000000 -0400
+@@ -42,7 +42,7 @@
+
+ sub ByteOf($)
+ {
+- return pack("c", $_[0]);
++ return pack("C", $_[0]);
+ }
+
+ sub ParseCommandline()