summaryrefslogtreecommitdiffstats
path: root/system/tmuxp/tmuxp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/tmuxp/tmuxp.SlackBuild')
-rw-r--r--system/tmuxp/tmuxp.SlackBuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/system/tmuxp/tmuxp.SlackBuild b/system/tmuxp/tmuxp.SlackBuild
index e1e4f02d0e..41c2f1ee19 100644
--- a/system/tmuxp/tmuxp.SlackBuild
+++ b/system/tmuxp/tmuxp.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for tmuxp
-# Copyright 2014-2019 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2020 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=tmuxp
-VERSION=${VERSION:-1.5.4}
+VERSION=${VERSION:-1.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -69,13 +69,13 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGES LICENSE PKG-INFO README.rst doc/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE PKG-INFO README.rst docs/*.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install