summaryrefslogtreecommitdiffstats
path: root/system/stressapptest
diff options
context:
space:
mode:
Diffstat (limited to 'system/stressapptest')
-rw-r--r--system/stressapptest/stressapptest.SlackBuild17
-rw-r--r--system/stressapptest/stressapptest.info6
-rw-r--r--system/stressapptest/support_i586.diff23
3 files changed, 21 insertions, 25 deletions
diff --git a/system/stressapptest/stressapptest.SlackBuild b/system/stressapptest/stressapptest.SlackBuild
index b1159a0124..ce0e6848bc 100644
--- a/system/stressapptest/stressapptest.SlackBuild
+++ b/system/stressapptest/stressapptest.SlackBuild
@@ -6,12 +6,15 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20231120 bkw: update for v1.0.11.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=stressapptest
-VERSION=${VERSION:-1.0.9}
+VERSION=${VERSION:-1.0.11}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -55,14 +58,8 @@ chown -R root:root .
find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
\! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-# This patch is based on Debian's support_i586_builds for
-# stressapptest-1.0.6. Extra logic here to avoid running autoreconf if
-# we don't need to (since it's slow). Allow PATCH=yes in the env for my
-# own testing purposes.
-if [ "${PATCH:-no}" = "yes" ]; then
- patch -p1 < $CWD/support_i586.diff
- autoreconf -if
-fi
+patch -p1 < $CWD/support_i586.diff
+autoreconf -if
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
@@ -91,4 +88,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/stressapptest/stressapptest.info b/system/stressapptest/stressapptest.info
index 61a387d14e..0fe038b71d 100644
--- a/system/stressapptest/stressapptest.info
+++ b/system/stressapptest/stressapptest.info
@@ -1,8 +1,8 @@
PRGNAM="stressapptest"
-VERSION="1.0.9"
+VERSION="1.0.11"
HOMEPAGE="https://github.com/stressapptest/stressapptest"
-DOWNLOAD="https://github.com/stressapptest/stressapptest/archive/v1.0.9/stressapptest-1.0.9.tar.gz"
-MD5SUM="d3a526c174c049dd7a1068dc74a62be2"
+DOWNLOAD="https://github.com/stressapptest/stressapptest/archive/v1.0.11/stressapptest-1.0.11.tar.gz"
+MD5SUM="bf1c1d73b44b65f8a1584a61b4605097"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/system/stressapptest/support_i586.diff b/system/stressapptest/support_i586.diff
index ca9d1302cd..18826c8076 100644
--- a/system/stressapptest/support_i586.diff
+++ b/system/stressapptest/support_i586.diff
@@ -1,23 +1,22 @@
-diff -Naur stressapptest-1.0.9/configure.ac stressapptest-1.0.9.patched/configure.ac
---- stressapptest-1.0.9/configure.ac 2018-08-09 20:01:24.000000000 -0400
-+++ stressapptest-1.0.9.patched/configure.ac 2020-06-06 13:34:23.000966542 -0400
-@@ -19,6 +19,10 @@
+--- stressapptest-1.0.11/configure.ac.orig 2024-05-16 06:24:36.806255976 +0700
++++ stressapptest-1.0.11/configure.ac 2024-05-16 06:25:18.914725236 +0700
+@@ -26,6 +26,10 @@
AC_DEFINE([STRESSAPPTEST_CPU_X86_64],[],
[Defined if the target CPU is x86_64])
- ],
+ ],
+ [*i586*], [
-+ AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
++ AC_DEFINE([STRESSAPPTEST_CPU_I586],[],
+ [Defined if the target CPU is i586])
-+ ],
++ ],
[*i686*], [
AC_DEFINE([STRESSAPPTEST_CPU_I686],[],
[Defined if the target CPU is i686])
-@@ -35,7 +39,7 @@
- AC_DEFINE([STRESSAPPTEST_CPU_AARCH64],[],
- [Defined if the target CPU is aarch64])
+@@ -50,7 +54,7 @@
+ AC_DEFINE([STRESSAPPTEST_CPU_LOONGARCH],[],
+ [Defined if the target CPU is LOONGARCH])
],
--[AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i686, powerpc, armv7a, or aarch64])]
-+[AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i586, i686, powerpc, armv7a, or aarch64])]
+-[AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i686, mips, powerpc, armv7a, aarch64 or loongarch])]
++[AC_MSG_WARN([Unsupported CPU: $host_cpu! Try x86_64, i586, i686, mips, powerpc, armv7a, aarch64 or loongarch])]
)
## The following allows like systems to share settings. This is not meant to