summaryrefslogtreecommitdiffstats
path: root/system/snore/snore.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/snore/snore.SlackBuild')
-rw-r--r--system/snore/snore.SlackBuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/system/snore/snore.SlackBuild b/system/snore/snore.SlackBuild
index f3db5a80c8..2f5d50fe53 100644
--- a/system/snore/snore.SlackBuild
+++ b/system/snore/snore.SlackBuild
@@ -6,12 +6,15 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20221228 bkw: update for v0.3.1, fix PKGTYPE, strip binary.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=snore
-VERSION=${VERSION:-0.2}
+VERSION=${VERSION:-0.3.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
@@ -58,6 +61,7 @@ sed -i -e 's,^pause for,pauses for,' \
sed -i "s|-Os|$SLKCFLAGS -Wl,-s|" config.mk
make
+strip $PRGNAM
make install PREFIX=/usr MANPREFIX=/usr/man DESTDIR=$PKG
gzip -9 $PKG/usr/man/man1/$PRGNAM.1
@@ -69,4 +73,4 @@ mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE