summaryrefslogtreecommitdiffstats
path: root/system/slpkg/slpkg.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/slpkg/slpkg.SlackBuild')
-rw-r--r--system/slpkg/slpkg.SlackBuild15
1 files changed, 3 insertions, 12 deletions
diff --git a/system/slpkg/slpkg.SlackBuild b/system/slpkg/slpkg.SlackBuild
index 4840d857f2..5f0b181588 100644
--- a/system/slpkg/slpkg.SlackBuild
+++ b/system/slpkg/slpkg.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for slpkg
-# Copyright 2014-2017 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2014-2018 Dimitris Zlatanidis Orestiada, Greece
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=slpkg
-VERSION=${VERSION:-3.3.2}
+VERSION=${VERSION:-3.3.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -56,9 +56,6 @@ fi
set -e
-PYTHON=python
-[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -75,13 +72,7 @@ find -L . \
# avoid install configuration files and man page over setup.py
sed -i 's/if "install"/if ""/' setup.py
-# Python 3 support
-if [ "$PYTHON3" = "yes" ]; then
- sh convert-py3k
- cd py3k/$PRGNAM
-fi
-
-$PYTHON setup.py install --root=$PKG
+python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true