summaryrefslogtreecommitdiffstats
path: root/system/sdltrs/sdltrs.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/sdltrs/sdltrs.SlackBuild')
-rw-r--r--system/sdltrs/sdltrs.SlackBuild149
1 files changed, 103 insertions, 46 deletions
diff --git a/system/sdltrs/sdltrs.SlackBuild b/system/sdltrs/sdltrs.SlackBuild
index 3ce93a807e..e04e9b64b3 100644
--- a/system/sdltrs/sdltrs.SlackBuild
+++ b/system/sdltrs/sdltrs.SlackBuild
@@ -4,6 +4,7 @@
# the Radio Shack TRS-80 Model I/III/4/4p emulator
# Copyright 2009-2010, 2012 Niels Horn, Rio de Janeiro, Brazil
+# Copyright 2023, B. Watson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,13 +24,49 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-# revision date 2012/08/09
+# 20240311 bkw, BUILD=2: having heard from upstream... the proper SDL2
+# version of sdltrs is in the sdl2 branch on his gitlab. This branch
+# (master) is the SDL-1.2 branch... though, confusingly, it does
+# support SDL2 (not in the modern way though, using hardware assisted
+# scaling and such). So. Modified the README to explain this, added
+# -DSDL1=true to the meson options, and added a completely new sdl2trs
+# build.
+# Also, include diskimages/*.dsk in the package (should have been there
+# all along, my bad).
+
+# 20240213 bkw: update for v1.2.28.
+
+# 20230524 bkw: previous update had wrong version number. use latest
+# git (with fix for .desktop file), with correct tag.
+
+# 20230517 bkw: update for latest git, v1.2.9a+20230517_29980234,
+# the sdl2 branch. This is done at the suggestion of the upstream
+# maintainer, because the master branch doesn't support SDL2's
+# hardware rendering and scaling. The binary changes names to
+# sdl2trs, so there's symlinks to the old name for now.
+
+# 20230418 bkw:
+# - new maintainer.
+# - update for v1.2.27 (make => meson, for one thing).
+# - patch to support system-wide ROM directory (which is shared
+# with xtrs).
+# - remove disk images from package (they're in trs80-roms now).
+# - use upstream's icon and .desktop.
+# - include man page in package.
+# - new version defaults to enabling the floppy drive, which causes
+# it to wait for a disk boot. add a README note explaining the
+# situation.
+
+# 20230418 bkw: Note: the default build is for SDL 2. It's still
+# possible to build with SDL 1, but I haven't bothered adding an
+# option for that. If you *really* need SDL 1 for some reason, let
+# me know.
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sdltrs
-VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-3}
+VERSION=${VERSION:-1.2.28}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -41,11 +78,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-SRCVERSION=$(echo $VERSION | tr . _)
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -58,61 +90,86 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
- ARCHQUADLET=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
LIBDIRSUFFIX=""
- ARCHQUADLET=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
- ARCHQUADLET=""
else
SLKCFLAGS="-O2"
LIBDIRSUFFIX=""
- ARCHQUADLET=""
fi
set -e
-rm -rf $TMP/${PRGNAM}_$SRCVERSION $PKG
+rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
+rm -rf $TMP/$PRGNAM-$VERSION
cd $TMP
-tar xvf $CWD/${PRGNAM}_$SRCVERSION.tar.gz
-cd ${PRGNAM}_$SRCVERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2 --exclude='*/bin/*' # debs/exes
+cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# include -lX11 in the Makefile (sw-14.0)
-sed "/^LIBS/s/= /= -lX11 /" -i src/linux/Makefile
-
-# the Makefile is in the src/linux directory
-make INCS="$SLKCFLAGS" -C src/linux
-
-# sdltrs does not have a "make install" option, so we'll do it manually
-mkdir -p $PKG/usr/bin
-cp -a src/linux/sdltrs $PKG/usr/bin
-strip --strip-unneeded $PKG/usr/bin/sdltrs
-
-# Copy icon & desktop file to package
-mkdir -p $PKG/usr/share/{applications,pixmaps}
-cat $CWD/sdltrs.desktop > $PKG/usr/share/applications/sdltrs.desktop
-cat $CWD/sdltrs.png > $PKG/usr/share/pixmaps/sdltrs.png
-
-# Make a directory for the ROMs (not included) and copy included images
-mkdir -p $PKG/usr/share/sdltrs
-cp -a diskimages/* $PKG/usr/share/sdltrs
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a BUILDING README $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a docs/* $PKG/usr/doc/$PRGNAM-$VERSION/html/
-find $PKG/usr/doc/$PRGNAM-$VERSION/ -type f -exec chmod 644 {} \;
+# upstream permissions are wonky, do not revert to template.
+find . -type f -a -exec chmod 644 {} + -o \
+ -type d -a -exec chmod 755 {} +
+
+# 20230417 bkw: Look in system-wide ROM directory by default.
+sed -i '/strcpy(romfile/s, ", "/usr/share/trs80-roms/,' src/trs_sdl_interface.c
+
+mkdir build
+cd build
+ CFLAGS="$SLKCFLAGS" \
+ CXXFLAGS="$SLKCFLAGS" \
+ meson .. \
+ -DSDL1=true \
+ --buildtype=release \
+ --infodir=/usr/info \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ -Dstrip=true
+ "${NINJA:=ninja}" -v
+ install -D -m0755 -s $PRGNAM $PKG/usr/games/$PRGNAM
+cd ..
+
+# 20230418 bkw: use upstream's man page, but section 6.
+mkdir -p $PKG/usr/man/man6
+sed -e '/^\.TH/s, 1 , 6 ,' \
+ -e '/^\.TH/s,$, SlackBuilds.org,' \
+ src/$PRGNAM.1 \
+ | gzip -9c > $PKG/usr/man/man6/$PRGNAM.6.gz
+
+sed -i -e 's,^Exec=,&/usr/games/,' $PRGNAM.desktop
+install -D -m0644 $PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+# 20230418 bkw: use upstream's icon, but pre-resized.
+HICOLOR=$PKG/usr/share/icons/hicolor
+SVGICON=icons/$PRGNAM.svg
+
+for px in 16 22 32 48 64 96 128; do
+ size=${px}x${px}
+ dir=$HICOLOR/$size/apps
+ mkdir -p $dir
+ rsvg-convert -w $px -h $px -o $dir/$PRGNAM.png $SVGICON
+done
+
+mkdir -p $HICOLOR/scalable/apps
+cp -a $SVGICON $HICOLOR/scalable/apps/$PRGNAM.svg
+
+mkdir -p $PKG/usr/share/pixmaps
+ln -s ../icons/hicolor/48x48/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+# Include the disk images upstream ships.
+mkdir -p $PKG/usr/share/$PRGNAM
+cp -a diskimages/*.dsk $PKG/usr/share/$PRGNAM
+
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
+cp -a CHANGELOG.md README.md *LICENSE utilities html $PKGDOC
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-chmod 755 $PKG/usr/doc/$PRGNAM-$VERSION/html/images/
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc