summaryrefslogtreecommitdiffstats
path: root/system/pycp/pycp.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/pycp/pycp.SlackBuild')
-rw-r--r--system/pycp/pycp.SlackBuild34
1 files changed, 6 insertions, 28 deletions
diff --git a/system/pycp/pycp.SlackBuild b/system/pycp/pycp.SlackBuild
index 173679b2d6..e0db9516ea 100644
--- a/system/pycp/pycp.SlackBuild
+++ b/system/pycp/pycp.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
-#
+
# Slackware build script for pycp.
-#
+
# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
# All rights reserved.
#
@@ -23,13 +23,13 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pycp
-VERSION=${VERSION:-7.1}
+VERSION=${VERSION:-7.2.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -40,27 +40,13 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/v$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -74,15 +60,7 @@ python setup.py install --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-PYTHONPATH=. help2man --no-info --output pycp.1 $PKG/usr/bin/pycp
-PYTHONPATH=. help2man --no-info --output pymv.1 $PKG/usr/bin/pymv
-mkdir -p $PKG/usr/man/man1
-cp -a pycp.1 pymv.1 $PKG/usr/man/man1/
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-DOCS="COPYING.txt README.txt PKG-INFO"
+DOCS="AUTHORS Changelog.rst COPYING.txt README.rst TODO"
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION