summaryrefslogtreecommitdiffstats
path: root/system/locust/locust.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/locust/locust.SlackBuild')
-rw-r--r--system/locust/locust.SlackBuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/system/locust/locust.SlackBuild b/system/locust/locust.SlackBuild
index 5fffa834b3..1c255a5c8f 100644
--- a/system/locust/locust.SlackBuild
+++ b/system/locust/locust.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for locust
-# Copyright 2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2021-2024 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=locust
-VERSION=${VERSION:-1.5.3}
+VERSION=${VERSION:-2.28.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -79,7 +76,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+# Since dependency python3-pyzmq uses a newer version of setuptools via
+# python3-setuptools-opt, we need to adjust PYTHONPATH to use it here too.
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --wheel --no-isolation
+
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true