summaryrefslogtreecommitdiffstats
path: root/system/localepurge
diff options
context:
space:
mode:
Diffstat (limited to 'system/localepurge')
-rw-r--r--system/localepurge/README14
-rw-r--r--system/localepurge/doinst.sh14
-rw-r--r--system/localepurge/locale.nopurge56
-rw-r--r--system/localepurge/localepurge.SlackBuild90
-rw-r--r--system/localepurge/localepurge.info10
-rw-r--r--system/localepurge/slack-desc19
6 files changed, 0 insertions, 203 deletions
diff --git a/system/localepurge/README b/system/localepurge/README
deleted file mode 100644
index 356b985a1e..0000000000
--- a/system/localepurge/README
+++ /dev/null
@@ -1,14 +0,0 @@
-localepurge (remove superfluous locale data)
-
-localepurge removes superfluous locale data from your system. It is
-a small script to recover disk space wasted for unneeded locale files
-and localized man pages.
-
-This is a script to recover disk space wasted for unneeded locales,
-Gnome/KDE localizations and localized man pages. Depending on the
-installation, it is possible to save some 200, 300, or even more
-megabytes of disk space dedicated to localization you will most
-probably never have any use for.
-
-Before use of localepurge, please edit /etc/locale.nopurge and comment
-out the line: NEEDSCONFIGFIRST.
diff --git a/system/localepurge/doinst.sh b/system/localepurge/doinst.sh
deleted file mode 100644
index a631ab8e99..0000000000
--- a/system/localepurge/doinst.sh
+++ /dev/null
@@ -1,14 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/locale.nopurge.new
diff --git a/system/localepurge/locale.nopurge b/system/localepurge/locale.nopurge
deleted file mode 100644
index 489a35d410..0000000000
--- a/system/localepurge/locale.nopurge
+++ /dev/null
@@ -1,56 +0,0 @@
-####################################################
-# This is the configuration file for localepurge(8).
-####################################################
-# Comment this to enable localepurge.
-# DO NOT COMMENT IT IF YOU ARE NOT SURE WHAT ARE YOU DOING
-# THIS APP DOES NOT ASK FOR CONFIRMATION
-
-NEEDSCONFIGFIRST
-
-####################################################
-# Uncommenting this string enables removal of localized
-# man pages based on the configuration information for
-# locale files defined below:
-
-MANDELETE
-
-####################################################
-# Uncommenting this string causes localepurge to simply delete
-# locales which have newly appeared on the system without
-# bothering you about it:
-
-#DONTBOTHERNEWLOCALE
-
-#####################################################
-# Commenting out this string enables faster but less
-# accurate calculation of freed disk space:
-
-#QUICKNDIRTYCALC
-
-####################################################
-# Uncommenting this string enables display of freed disk
-# space if localepurge has purged any superfluous data:
-
-SHOWFREEDSPACE
-
-#####################################################
-# Commenting out this string disables verbose output:
-
-#VERBOSE
-
-#####################################################
-# You like Colors?
-
-#NOCOLOR
-
-#####################################################
-# You can use the -v -d -nc options in command line.
-
-#####################################################
-# Following locales won't be deleted from this system
-# for example:
-en
-en_GB
-en_GB.UTF-8
-en_US
-en_US.UTF-8
diff --git a/system/localepurge/localepurge.SlackBuild b/system/localepurge/localepurge.SlackBuild
deleted file mode 100644
index 1dac37dfc4..0000000000
--- a/system/localepurge/localepurge.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/bash
-#
-# Slackware build script for localepurge.
-#
-# Copyright 2016-2021 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220212 bkw: Modified by SlackBuilds.org:
-# - stop writing to $CWD. *nothing* should *ever* do this.
-# - make this a noarch package since there's no compiled code.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=localepurge
-VERSION=${VERSION:-0.7.3.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-ARCH=noarch
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-install -D -m755 usr/sbin/localepurge $PKG/usr/bin/localepurge
-install -D -m644 debian/localepurge.8 $PKG/usr/man/man8/localepurge.8
-install -D -m755 debian/localepurge.config $PKG/usr/bin/localepurge-config
-install -D -m644 $CWD/locale.nopurge $PKG/etc/locale.nopurge.new
-
-gzip $PKG/usr/man/man*/*
-
-CACHEDIR=$PKG/var/cache/localepurge/localelist
-mkdir -p $CACHEDIR
-
-find /usr/share/locale -maxdepth 1 -type d -name "*" -printf "%f\n" | \
- grep "^[a-z]" | \
- cut -d" " -f1 | \
- sort -u \
- > $CACHEDIR/localelist
-
-DOCS="debian/README.Debian debian/changelog debian/copyright"
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/localepurge/localepurge.info b/system/localepurge/localepurge.info
deleted file mode 100644
index 6014256630..0000000000
--- a/system/localepurge/localepurge.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="localepurge"
-VERSION="0.7.3.10"
-HOMEPAGE="https://packages.debian.org/search?keywords=localepurge"
-DOWNLOAD="http://deb.debian.org/debian/pool/main/l/localepurge/localepurge_0.7.3.10.tar.xz"
-MD5SUM="cafa19c565e5156c7947c0094fe76a3c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Edinaldo P. Silva"
-EMAIL="edps.mundognu@gmail.com"
diff --git a/system/localepurge/slack-desc b/system/localepurge/slack-desc
deleted file mode 100644
index c8d5740550..0000000000
--- a/system/localepurge/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-localepurge: localepurge (remove superfluous locale data)
-localepurge:
-localepurge: localepurge removes superfluous locale data from your system. It is a
-localepurge: small script to recover disk space wasted for unneeded locale files
-localepurge: and localized man pages.
-localepurge:
-localepurge: Homepage: https://packages.debian.org/search?keywords=localepurge
-localepurge:
-localepurge:
-localepurge:
-localepurge: