summaryrefslogtreecommitdiffstats
path: root/system/localepurge/localepurge.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/localepurge/localepurge.SlackBuild')
-rw-r--r--system/localepurge/localepurge.SlackBuild90
1 files changed, 0 insertions, 90 deletions
diff --git a/system/localepurge/localepurge.SlackBuild b/system/localepurge/localepurge.SlackBuild
deleted file mode 100644
index 1dac37dfc4..0000000000
--- a/system/localepurge/localepurge.SlackBuild
+++ /dev/null
@@ -1,90 +0,0 @@
-#!/bin/bash
-#
-# Slackware build script for localepurge.
-#
-# Copyright 2016-2021 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# 20220212 bkw: Modified by SlackBuilds.org:
-# - stop writing to $CWD. *nothing* should *ever* do this.
-# - make this a noarch package since there's no compiled code.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=localepurge
-VERSION=${VERSION:-0.7.3.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-ARCH=noarch
-
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.xz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-
-install -D -m755 usr/sbin/localepurge $PKG/usr/bin/localepurge
-install -D -m644 debian/localepurge.8 $PKG/usr/man/man8/localepurge.8
-install -D -m755 debian/localepurge.config $PKG/usr/bin/localepurge-config
-install -D -m644 $CWD/locale.nopurge $PKG/etc/locale.nopurge.new
-
-gzip $PKG/usr/man/man*/*
-
-CACHEDIR=$PKG/var/cache/localepurge/localelist
-mkdir -p $CACHEDIR
-
-find /usr/share/locale -maxdepth 1 -type d -name "*" -printf "%f\n" | \
- grep "^[a-z]" | \
- cut -d" " -f1 | \
- sort -u \
- > $CACHEDIR/localelist
-
-DOCS="debian/README.Debian debian/changelog debian/copyright"
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE