summaryrefslogtreecommitdiffstats
path: root/system/letsencrypt/letsencrypt.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/letsencrypt/letsencrypt.SlackBuild')
-rw-r--r--system/letsencrypt/letsencrypt.SlackBuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/system/letsencrypt/letsencrypt.SlackBuild b/system/letsencrypt/letsencrypt.SlackBuild
index 6c4c002267..efa6a48fea 100644
--- a/system/letsencrypt/letsencrypt.SlackBuild
+++ b/system/letsencrypt/letsencrypt.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for letsencrypt
-# Copyright 2015-2019 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
+# Copyright 2015-2020 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=letsencrypt
SRCNAM=certbot
-VERSION=${VERSION:-1.0.0}
+VERSION=${VERSION:-1.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -80,24 +80,24 @@ done
# install acme-protocol first
cd acme
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install letsencrypt client
cd ../certbot
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
# install apache plugin
cd ../certbot-apache
-python setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
cd ..
# install nginx plugin
#cd ../certbot-nginx
-#python setup.py install --root=$PKG
+#python3 setup.py install --root=$PKG
# We include default options for Apache
mkdir -p $PKG/etc/letsencrypt/
-cp $PKG/usr/lib${LIBDIRSUFFIX}/python2.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
+cp $PKG/usr/lib${LIBDIRSUFFIX}/python3.7/site-packages/certbot_apache/_internal/options-ssl-apache.conf \
$PKG/etc/letsencrypt/options-ssl-apache.conf
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \