summaryrefslogtreecommitdiffstats
path: root/system/iotop/iotop.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/iotop/iotop.SlackBuild')
-rw-r--r--system/iotop/iotop.SlackBuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/system/iotop/iotop.SlackBuild b/system/iotop/iotop.SlackBuild
index 0ab919d361..a4b622ecb2 100644
--- a/system/iotop/iotop.SlackBuild
+++ b/system/iotop/iotop.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for iotop
-# Copyright 2012 Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2012-2013 Audrius Kažukauskas <audrius@neutrino.lt>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=iotop
-VERSION=${VERSION:-0.4.4}
+VERSION=${VERSION:-0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,16 +49,17 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+chmod -R u+w,go+r-w,a-s+X .
-sed -i 's|share/man/man1|man/man1|' setup.py
+sed -i 's|share/man/man8|man/man8|' setup.py
python setup.py install --root=$PKG
+# iotop script is placed in sbin directory inside source tarball, also in NEWS
+# there's a note that it should be installed to sbin, but setup.py doesn't do
+# this, so we'll fix it ourselves.
+mv $PKG/usr/bin $PKG/usr/sbin
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done