summaryrefslogtreecommitdiffstats
path: root/system/gnomint/patches
diff options
context:
space:
mode:
Diffstat (limited to 'system/gnomint/patches')
-rw-r--r--system/gnomint/patches/01-ldd.patch14
-rw-r--r--system/gnomint/patches/02-cflags.patch28
-rw-r--r--system/gnomint/patches/gnutls3.patch31
3 files changed, 73 insertions, 0 deletions
diff --git a/system/gnomint/patches/01-ldd.patch b/system/gnomint/patches/01-ldd.patch
new file mode 100644
index 0000000000..0f92419fb0
--- /dev/null
+++ b/system/gnomint/patches/01-ldd.patch
@@ -0,0 +1,14 @@
+Author: Daniel Baumann <daniel@debian.org>
+Description: Explicitly linking against libgcrypt.
+
+diff -Naurp gnomint.orig/src/Makefile.in gnomint/src/Makefile.in
+--- gnomint.orig/src/Makefile.in 2011-05-17 19:57:50.013883380 +0200
++++ gnomint/src/Makefile.in 2011-05-17 19:57:37.209981808 +0200
+@@ -347,6 +347,7 @@ gnomint_cli_SOURCES = \
+
+ gnomint_cli_LDADD = \
+ $(GNOMINTCLI_LIBS) \
++ $(LIBGCRYPT_LIBS) \
+ $(LIBGNUTLS_LIBS) \
+ $(SQLITE_LIBS) \
+ $(READLINE_LIBS) \
diff --git a/system/gnomint/patches/02-cflags.patch b/system/gnomint/patches/02-cflags.patch
new file mode 100644
index 0000000000..59e4f71943
--- /dev/null
+++ b/system/gnomint/patches/02-cflags.patch
@@ -0,0 +1,28 @@
+Author: Daniel Baumann <daniel@debian.org>
+Description:
+ Don't hardcode CFLAGS and respect the environemnt (Closes: #634395).
+
+diff -Naurp gnomint.orig/configure gnomint/configure
+--- gnomint.orig/configure 2011-09-08 07:58:09.324752523 +0000
++++ gnomint/configure 2011-09-08 07:59:20.113103539 +0000
+@@ -14338,7 +14338,7 @@ fi
+
+
+ if test "x$GCC" = "xyes"; then
+- CFLAGS="-Wall -Werror"
++ CFLAGS="${CFLAGS:--Wall -Werror}"
+ if test "x$use_debug" = "xYes"; then
+ CFLAGS="$CFLAGS -g -O0"
+ fi
+diff -Naurp gnomint.orig/configure.in gnomint/configure.in
+--- gnomint.orig/configure.in 2011-09-08 07:58:09.328752536 +0000
++++ gnomint/configure.in 2011-09-08 07:59:20.113103539 +0000
+@@ -181,7 +181,7 @@ dnl
+
+ dnl
+ if test "x$GCC" = "xyes"; then
+- CFLAGS="-Wall -Werror"
++ CFLAGS="${CFLAGS:--Wall -Werror}"
+ if test "x$use_debug" = "xYes"; then
+ CFLAGS="$CFLAGS -g -O0"
+ fi
diff --git a/system/gnomint/patches/gnutls3.patch b/system/gnomint/patches/gnutls3.patch
new file mode 100644
index 0000000000..8ee3371884
--- /dev/null
+++ b/system/gnomint/patches/gnutls3.patch
@@ -0,0 +1,31 @@
+diff -aur a/src/import.c b/src/import.c
+--- a/src/import.c 2010-05-31 23:01:37.000000000 +0200
++++ b/src/import.c 2012-06-27 17:50:06.993671796 +0200
+@@ -695,7 +695,7 @@
+
+ // After having all the parts unencrypted, we import all certificates first.
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {
+@@ -722,7 +722,7 @@
+
+ // Then, we import all PKCS8 private keys.
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {
+@@ -796,7 +796,7 @@
+ // Then we import the CRLs
+
+ for (i=0; i<n_bags; i++) {
+- gnutls_pkcs12_bag * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
++ gnutls_pkcs12_bag_t * pkcs12_bag = g_array_index (pkcs_bag_array, gnutls_pkcs12_bag_t *, i);
+ guint num_elements_in_bag = gnutls_pkcs12_bag_get_count (*pkcs12_bag);
+
+ for (i=0; i < num_elements_in_bag; i++) {
+Nur in b/src: import.c~.