summaryrefslogtreecommitdiffstats
path: root/system/gnome-vfs
diff options
context:
space:
mode:
Diffstat (limited to 'system/gnome-vfs')
-rw-r--r--system/gnome-vfs/gnome-vfs.SlackBuild2
-rw-r--r--system/gnome-vfs/openssl-1.1.patch26
2 files changed, 28 insertions, 0 deletions
diff --git a/system/gnome-vfs/gnome-vfs.SlackBuild b/system/gnome-vfs/gnome-vfs.SlackBuild
index 2a2e087339..3b7809d74c 100644
--- a/system/gnome-vfs/gnome-vfs.SlackBuild
+++ b/system/gnome-vfs/gnome-vfs.SlackBuild
@@ -69,6 +69,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+patch -p0 < $CWD/openssl-1.1.patch
+
# Fix for the newer glib
sed -i "/-DG_DISABLE_DEPRECATED/d" */Makefile.*
diff --git a/system/gnome-vfs/openssl-1.1.patch b/system/gnome-vfs/openssl-1.1.patch
new file mode 100644
index 0000000000..14207f28d1
--- /dev/null
+++ b/system/gnome-vfs/openssl-1.1.patch
@@ -0,0 +1,26 @@
+$NetBSD: patch-libgnomevfs_gnome-vfs-ssl.c,v 1.1 2018/02/16 13:18:26 wiz Exp $
+
+struct SSL is opaque in openssl-1.1; and the SSL_free() man page
+says that one should not free members of it manually (in both
+the openssl-1.0 and openssl-1.1 man pages).
+
+--- libgnomevfs/gnome-vfs-ssl.c.orig 2010-02-09 12:16:14.000000000 +0000
++++ libgnomevfs/gnome-vfs-ssl.c
+@@ -400,9 +400,6 @@ gnome_vfs_ssl_create_from_fd (GnomeVFSSS
+ }
+ }
+
+- if (ssl->private->ssl->ctx)
+- SSL_CTX_free (ssl->private->ssl->ctx);
+-
+ SSL_free (ssl->private->ssl);
+ g_free (ssl->private);
+ g_free (ssl);
+@@ -705,7 +702,6 @@ gnome_vfs_ssl_destroy (GnomeVFSSSL *ssl,
+ }
+ }
+
+- SSL_CTX_free (ssl->private->ssl->ctx);
+ SSL_free (ssl->private->ssl);
+ close (ssl->private->sockfd);
+ if (ssl->private->timeout)