summaryrefslogtreecommitdiffstats
path: root/system/fprintd/fprintd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/fprintd/fprintd.SlackBuild')
-rw-r--r--system/fprintd/fprintd.SlackBuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/system/fprintd/fprintd.SlackBuild b/system/fprintd/fprintd.SlackBuild
index 0f895acf79..c880e58f18 100644
--- a/system/fprintd/fprintd.SlackBuild
+++ b/system/fprintd/fprintd.SlackBuild
@@ -27,7 +27,7 @@ cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=fprintd
VERSION=${VERSION:-1.94.2}
SRCVERSION=v${VERSION}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -77,18 +77,26 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Disable tests since tehy require various python modules
-sed '154,158 {s/^/#/}' -i meson.build
-sed '204,205 {s/^/#/}' -i meson.build
-sed -e "/subdir('tests')/ s/^#*/#/" -i meson.build
+# Patches
+if [ -d $CWD/patches ]; then
+ for file in $CWD/patches/*.patch ; do
+ if [ -f $file ]; then
+ cat $file | patch -p1 --verbose || exit 1
+ fi
+ done
+fi
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
- meson .. \
+ meson setup .. \
+ -Dman=true \
+ -Dgtk_doc=false \
-Dsystemd=false \
- -Dpam=false \
+ -Dlibsystemd=libelogind \
+ -Dpam=true \
+ -Dpam_modules_dir=/lib${LIBDIRSUFFIX}/security \
--buildtype=release \
--infodir=/usr/info \
--libdir=/usr/lib${LIBDIRSUFFIX} \