summaryrefslogtreecommitdiffstats
path: root/system/epson-printer-utility/epson-printer-utility.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/epson-printer-utility/epson-printer-utility.SlackBuild')
-rw-r--r--system/epson-printer-utility/epson-printer-utility.SlackBuild170
1 files changed, 27 insertions, 143 deletions
diff --git a/system/epson-printer-utility/epson-printer-utility.SlackBuild b/system/epson-printer-utility/epson-printer-utility.SlackBuild
index c8fc095f2d..0e87b2491c 100644
--- a/system/epson-printer-utility/epson-printer-utility.SlackBuild
+++ b/system/epson-printer-utility/epson-printer-utility.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for epson-printer-utility
-# Copyright 2020/2022 Tim Dickson
+# Copyright 2020-2024 Tim Dickson
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -30,17 +30,16 @@
# - fix weird libtool issue (libcutils.la wasn't being built).
# - stop writing to $CWD. use a top-level build dir instead.
# - fix hardcoded /usr/lib64 in rm command (fix build on 32-bit)!
-
-# 20220522 tim dickson: Build=5: update README.models to include new
-# - models. Also major patching to get working with qt5, removing qt4 dep
+# in 1.1.2 epson updated things so it actually works with qt5 now.
+# 20240131 update to 1.1.3
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=epson-printer-utility
-VERSION=${VERSION:-1.1.1}
-EXTRABIT=1lsb3.2
-TARNAM=$PRGNAM-$VERSION.tar.gz
-BUILD=${BUILD:-5}
+VERSION=${VERSION:-1.1.3}
+EXTRABIT=1
+TARNAM=$PRGNAM-$VERSION-$EXTRABIT.src.tgz
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -82,9 +81,6 @@ set -e
TOPDIR=$TMP/$PRGNAM-$VERSION-build
-##this is my attempt to patch the software to work with qt5
-#source /etc/profile.d/qt4.sh; export PATH
-
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
@@ -95,15 +91,12 @@ cd $TOPDIR
#lets get the source tarball from the rpm and clean up the bits we don't need
ln -s $CWD/$PRGNAM-$VERSION-$EXTRABIT.src.rpm .
rpm2tgz $PRGNAM-$VERSION-$EXTRABIT.src.rpm
-tar xvf $PRGNAM-$VERSION-$EXTRABIT.src.tgz
-rm $PRGNAM-$VERSION-$EXTRABIT.src.tgz
-
-tar xvf $TARNAM
-#we remove the tarnam as the original is an rpm
-#this keeps things tidy.
+rm $PRGNAM-$VERSION-$EXTRABIT.src.rpm
+tar xzf $TARNAM
rm $TARNAM
-
-cd $PRGNAM-$VERSION
+tar xzf epson-printer-utility.tar.gz
+tar xzf epson-backend.tar.gz
+cd $PRGNAM
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -112,68 +105,17 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
echo "patch configure.ac"
-sed -i 's_/opt/lsb/bin/lsbc++_/usr/bin/c++_g' configure.ac
+#remove automake error, fix udev typo and fix qt source paths
sed -i '/^AM_INIT_AUTOMAKE/a AM_PROG_AR()' configure.ac
-#fix typo in path of udev stuff
sed -i 's_/ect_/etc_g' configure.ac
-#fix source code. We shouldn't have to do this, but hey ho!....
-mv EPSCommonLib/epsmp/linux/XAsyncSocket.cpp EPSCommonLib/epsmp/linux/XAsyncSocket.c
-#patch png files to remove incorrect sRGB profile in all of them.
-mogrify -strip PrinterUtility/Images/*.png
-#patch the Resources.qrc file to include missing png's
-sed -i 'sZInklow.png</file>ZInklow.png</file>\n <file>Images/Inklow_.png</file>\n <file>Images/printer_status_OLD.png</file>\n <file>Images/printer_status_error_laser.png</file>\n <file>Images/printer_status_warning_laser.png</file>\n <file>Images/warning.png</file>Zg' PrinterUtility/Resources.qrc
-#we need to regenerate qrc_Resources.cpp (which would have been generated by qmake)
-#as the one shipped has all the png's with iCCP invalid sRGB profiles.
-#echo "create new qrc_resources.cpp file using our patched Resources.qrc file"
-#and patch source so it can find class definition for qt5
-
-cd PrinterUtility
-sed -i '1i_QT += widgets' PrinterUtility.pro
-rm -f qrc_Resources.cpp
-rcc -o qrc_Resources.cpp Resources.qrc
-sed -i 's_QWidget>_QWidget>\n#include "qboxlayout.h"\n#include "qlabel.h"_g' EPUView.h
-sed -i 's_Controller.h"_Controller.h"\n#include "qpushbutton.h"_g' EPUMaintenanceGuideView.h
-sed -i 's_QDialog>_QDialog>\n#include "qlistview.h"\n#include "qpushbutton.h"\n#include "qboxlayout.h"\n#include "qapplication.h"_g' EPUPrinterListDialog.h
-sed -i 's_QTimer>_QTimer>\n#include "qgroupbox.h"_g' EPUMainView.h
-sed -i 's_QTimer>_QTimer>\n#include "qapplication.h"_g' EPUMainController.cpp
-sed -i 's_QFont>_QFont>\n#include "qapplication.h"\n#include "qdesktopwidget.h"_g' EPUMainWindow.cpp
-
-cd ..
-
-#echo "now we have a resources file with fixed pngs embeded in it"
-#lets run qmake :-) - or lets not. it looks like a bunch of stuff is missing.!
-#the list of stuff reported missing by qmake was sent to linux-printer@epson.jp 28/09/2020
-#with a request for them to include the missing source code. hopefully they will supply
-#the missing code, so we can update this script and remove some of the patches.
-
-#keep next few lines incase we can actually use it in the future.
-#cd PrinterUtility
-#qmake PrinterUtility.pro
-#cd ..
-
-echo "===fix Makefile.am files prior to running autoreconf==="
-#fix hardcoded /opt/lsb stuff so that autoreconf generates correct Makefile.in
-sed -i 's_/opt/lsb_/usr_g' EPSCommonLib/Makefile.am
-sed -i 's_/libQt_/libQt5_g' EPSCommonLib/Makefile.am
-sed -i 's_usr/include_usr/include/qt5_g' EPSCommonLib/Makefile.am
-
-sed -i 's_/opt/lsb_/usr_g' PrinterUtility/Makefile.am
-sed -i 's_usr/include_usr/include/qt5_g' PrinterUtility/Makefile.am
-sed -i 's_qt5/QtNetwork_qt5/QtNetwork \\\n -I/usr/include/qt5/QtWidgets_g' PrinterUtility/Makefile.am
-sed -i 's_libQt_libQt5_g' PrinterUtility/Makefile.am
-sed -i 's_libcups.so_libcups.so \\\n /usr/\$\(LIBARCH\)/libQt5Widgets.so_g' PrinterUtility/Makefile.am
+sed -i 'sZ/opt/Qt/5.15.0/gcc_64/includeZ/usr/include/qt5Zg' configure.ac
-echo "running aclocal"
aclocal
-echo "running autoreconf"
autoreconf --install --force
-
-echo "================="
-echo "running configure"
-echo "================="
-#CFLAGS="$SLKCFLAGS -fpermissive -I/usr/include/qt5 -I/usr/include/qt5/QtCore" \
-#CXXFLAGS="$SLKCFLAGS -fpermissive -I/usr/include/qt5 -I/usr/include/qt5/QtCore" \
-
+#patch things to point to the correct dir
+echo "patch makefile.am configs"
+sed -i "sZ/x86_64-linux-gnu/qt5Z/qt5Zg" EPSCommonLib/Makefile.am
+sed -i "sZ/x86_64-linux-gnu/qt5Z/qt5Zg" PrinterUtility/Makefile.am
CC=/usr/bin/c++ \
CXX=/usr/bin/c++ \
@@ -182,7 +124,6 @@ CXXFLAGS="$SLKCFLAGS -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib${LIBDIRSUFFIX} \
- --includedir=/usr/include/qt5 \
--sysconfdir=/etc \
--localstatedir=/var \
--mandir=/usr/man \
@@ -191,47 +132,12 @@ CXXFLAGS="$SLKCFLAGS -fpermissive" \
--disable-static \
--build=$ARCH-slackware-linux
-echo "more patching of source files"
-#add missing header for sleep
-sed -i "1 i #include <unistd.h>" PrinterUtility/EPUMainController.cpp
-sed -i "1 i #include <unistd.h>" PrinterUtility/EPUPrinterListDialog.cpp
-#we need to patch the moc files so they work with qt 5.15.3 that ships with slackware 15.0
-#when the source is complete and we can run qmake, that should fix this
-#for qt 5.15.3 MOC_OUTPUT_REVISION is 67 this number can be found in
-#/usr/include/qt5/QtCore/qobjectdefs.h
-
-#fix moc files so version check works with qt5.15.3
-#we do this because epson is missing the NozzlecheckResultView.h
-#file, so we can't recreate it.
-for i in `ls PrinterUtility/moc_*.cpp`; do
- sed -i 's/59/67/g' $i
-done
-#lets recreate moc files from .h files
-cd PrinterUtility
- for i in EPUMainView EPUMainWindow EPUMaintenanceGuideView EPUOperationView EPUPrinterListDialog EPUView ;do
- rm moc_$i.cpp #remove existing moc file
- moc $i.h >moc_$i.cpp #create new moc file
- done
- rm moc_EThread.cpp
- moc ../EPUCommon/EThread.h >moc_EThread.cpp
-cd ..
-#this one is taken from outside the directory
-
-#patch hardcoded path in Main.cpp so it can find language files
+##patch hardcoded path in Main.cpp so it can find language files
+echo "patch Main.cpp to fix language file paths"
sed -i "s_/opt/epson_/usr/share/epson_g" PrinterUtility/Main.cpp
-#fix linking to qt5 stuff instead of qt4. should be fixed with .am fix
-#sed -i "s_libQt_libQt5_g" EPSCommonLib/Makefile.in
-echo "=================="
-echo "running make"
-echo "============="
-
make
-
-echo "============"
-echo "running make install"
-
make install DESTDIR=$PKG
-#as make install doesn't do much we do it manually
+#as make install doesn't do much we sort it out manually
mkdir -p $PKG/usr/bin
cp -a PrinterUtility/epson-printer-utility $PKG/usr/bin/
#udev rule to allow set permissions so any user can monitor the printer.
@@ -242,17 +148,8 @@ mv $PKG/usr/resource/Languages/*.qm $PKG/usr/share/epson-printer-utility/resourc
rm -r $PKG/usr/resource
mkdir -p $PKG/usr/share/pixmaps
cp PrinterUtility/Images/AppIcon.png $PKG/usr/share/pixmaps/epson-printer-utility.png
-#+-----------------------------------------------------------+
-#| we now have to process the communication daemon |
-#+-----------------------------------------------------------+
-echo "qt part of utility done, now for daemon"
-cd $TOPDIR
-rm -rf epson-backend-$VERSION
-tar xvf epson-backend-$VERSION.tar.gz
-#we remove the tarnam as the original is an rpm
-#this keeps things tidy.
-rm epson-backend-$VERSION.tar.gz
-cd epson-backend-$VERSION
+#=====now for backend.
+cd $TOPDIR/epson-backend
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -260,13 +157,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-echo "running aclocal"
+#i don't think next line is needed. Seems to work without it.
aclocal
-echo "running autoreconf"
+#next line is needed to make things work with 1.1.3
+touch m4-macros
autoreconf --install --force
-echo "running configure"
-
CC=/usr/bin/gcc \
CXX=/usr/bin/c++ \
CFLAGS="$SLKCFLAGS -Wno-unused-but-set-variable -Wno-unused-function -Wno-implicit-function-declaration -Wno-pointer-sign -Wno-unused-variable" \
@@ -281,22 +177,10 @@ CXXFLAGS="$SLKCFLAGS -fpermissive" \
--disable-static \
--build=$ARCH-slackware-linux
-echo "patching source for backend daemon. epmnt.c"
+#we need to patch the source
sed -i "1 i #include <stdlib.h>\n#include <string.h>" daemon/epmnt.c
-echo "running make"
-make -C src libcutils.la # 20220307 bkw: this one wasn't being made
make
-echo "running make install"
make install DESTDIR=$PKG
-
-#now lets tidy everything up. after all, we are not debian :-)
-#there are three important program files, /usr/bin/epson-printer-utility
-#/usr/lib/epson-backend/ecbd the communication daemon, and
-#/usr/lib64/cups/backend/ecblp the cups backend
-#we will trash the contents of /usr/lib64/epson-backend for now, it looks like it is just debian daemon stuff.
-#we need to create our own rc.ecbd file to start/stop/restart the backend
-#this should be added into rc.local to make it active at startup
-rm -r $PKG/usr/lib$LIBDIRSUFFIX/epson-backend
mkdir -p $PKG/etc/rc.d
cp $CWD/rc.ecbd $PKG/etc/rc.d/rc.ecbd.new
#the utility won't work without the daemon, so reduce steps admin has to do to get