summaryrefslogtreecommitdiffstats
path: root/system/driconf/driconf.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/driconf/driconf.SlackBuild')
-rw-r--r--system/driconf/driconf.SlackBuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/system/driconf/driconf.SlackBuild b/system/driconf/driconf.SlackBuild
index 1768dac18a..d344b866ff 100644
--- a/system/driconf/driconf.SlackBuild
+++ b/system/driconf/driconf.SlackBuild
@@ -21,6 +21,8 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Thanks to James Powell for the .desktop file.
+
PRGNAM=driconf
VERSION=${VERSION:-0.9.1}
BUILD=${BUILD:-1}
@@ -72,6 +74,11 @@ cat $CWD/driconf-0.9.1-2.diff | patch --verbose -p1
python setup.py install --root=$PKG
+mkdir -p $PKG/usr/share/{applications,driconf}
+ cp -a $CWD/driconf.desktop $PKG/usr/share/applications/driconf.desktop
+ cp -a driconf-icon.png $PKG/usr/share/applications/driconf-icon.png
+
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true