summaryrefslogtreecommitdiffstats
path: root/system/docker-compose
diff options
context:
space:
mode:
Diffstat (limited to 'system/docker-compose')
-rw-r--r--system/docker-compose/README22
-rw-r--r--system/docker-compose/docker-compose.SlackBuild37
-rw-r--r--system/docker-compose/docker-compose.info16
-rw-r--r--system/docker-compose/doinst.sh8
-rw-r--r--system/docker-compose/slack-desc14
5 files changed, 57 insertions, 40 deletions
diff --git a/system/docker-compose/README b/system/docker-compose/README
index c2fe93df16..11259004f9 100644
--- a/system/docker-compose/README
+++ b/system/docker-compose/README
@@ -1,7 +1,17 @@
-Compose is a tool for defining and running multi-container Docker
-applications. With Compose, you use a Compose file to configure your
-application's services. Then, using a single command, you create and
-start all the services from your configuration.
+Docker Compose v2 (Utility for running containers on Docker)
-Compose is great for development, testing, and staging environments, as
-well as CI workflows.
+Docker Compose is a tool for running multi-container applications on
+Docker defined using the Compose file format. A Compose file is used to
+define how one or more containers that make up your application are
+configured. Once you have a Compose file, you can create and start your
+application with a single command: docker compose up.
+
+Docker Compose V2 is a major version bump release of Docker Compose. It
+has been completely rewritten from scratch in Golang (V1 was in Python).
+The installation instructions for Compose V2 differ from V1. V2 is not a
+standalone binary anymore, and installation scripts will have to be
+adjusted. Some commands are different.
+
+Warning: This SlackBuild requires network access when it runs, meaning
+it downloads files from the Internet with root access. You should
+decide for yourself whether or not you think this is a good idea.
diff --git a/system/docker-compose/docker-compose.SlackBuild b/system/docker-compose/docker-compose.SlackBuild
index 1d58c12e12..b34eeb8d87 100644
--- a/system/docker-compose/docker-compose.SlackBuild
+++ b/system/docker-compose/docker-compose.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for docker-compose
-# Copyright 2017-2018 Audrius Kažukauskas <audrius@neutrino.lt>
+# Copyright 2023 Ebben Aries <slackbuilds@dscp.org>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,11 +25,14 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=docker-compose
-VERSION=${VERSION:-1.21.1}
+VERSION=${VERSION:-2.27.0}
+GITHASH=${GITHASH:-b929810}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+SRCNAM=compose
+
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i586 ;;
@@ -38,9 +41,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -55,9 +55,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -65,25 +65,24 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Remove upper bound on requires.
-sed -i "s/, < .*',$/',/" setup.py
+GO111MODULE=auto \
+DISABLE_WARN_OUTSIDE_CONTAINER=1 \
+make \
+ GITCOMMIT=$GITHASH \
+ VERSION=$VERSION
-python2 setup.py install --root=$PKG
+install -D -m 0755 bin/build/$PRGNAM $PKG/usr/bin/$PRGNAM
-# Completion.
-install -D -m 0644 contrib/completion/bash/docker-compose \
- $PKG/usr/share/bash-completion/completions/docker-compose
-install -D -m 0644 contrib/completion/zsh/_docker-compose \
- $PKG/usr/share/zsh/site-functions/_docker-compose
-install -D -m 0644 contrib/completion/fish/docker-compose.fish \
- $PKG/usr/share/fish/vendor_completions.d/docker-compose.fish
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a CHANGELOG.md LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a BUILDING.md LICENSE MAINTAINERS NOTICE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/docker-compose/docker-compose.info b/system/docker-compose/docker-compose.info
index 6f39173a6f..1f77fc084d 100644
--- a/system/docker-compose/docker-compose.info
+++ b/system/docker-compose/docker-compose.info
@@ -1,10 +1,10 @@
PRGNAM="docker-compose"
-VERSION="1.21.1"
+VERSION="2.27.0"
HOMEPAGE="https://docs.docker.com/compose/"
-DOWNLOAD="https://files.pythonhosted.org/packages/04/93/8547a7701e44b0ea24735d1950fe7e6fe90951f0ebb6757dabf76ee64473/docker-compose-1.21.1.tar.gz"
-MD5SUM="9dbc93a798fcda7b871ed6d580dc1a18"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python2-PyYAML docopt jsonschema python2-cached-property python2-docker python2-dockerpty python2-texttable"
-MAINTAINER="Audrius Kažukauskas"
-EMAIL="audrius@neutrino.lt"
+DOWNLOAD="UNSUPPORTED"
+MD5SUM=""
+DOWNLOAD_x86_64="https://github.com/docker/compose/archive/v2.27.0/compose-2.27.0.tar.gz"
+MD5SUM_x86_64="19c94f1323a155d19afbfeda1cdecbcc"
+REQUIRES="docker-cli"
+MAINTAINER="Ebben Aries"
+EMAIL="slackbuilds@dscp.org"
diff --git a/system/docker-compose/doinst.sh b/system/docker-compose/doinst.sh
new file mode 100644
index 0000000000..a05dcabbd4
--- /dev/null
+++ b/system/docker-compose/doinst.sh
@@ -0,0 +1,8 @@
+# Install docker-compose to docker-cli global plugin directory
+PLUGIN_DIR="/usr/libexec/docker/cli-plugins"
+
+if [ ! -d "$PLUGIN_DIR" ]; then
+ mkdir -p $PLUGIN_DIR
+fi
+
+ln -sf /usr/bin/docker-compose $PLUGIN_DIR/docker-compose
diff --git a/system/docker-compose/slack-desc b/system/docker-compose/slack-desc
index 4ce7ddc508..82c2b7d297 100644
--- a/system/docker-compose/slack-desc
+++ b/system/docker-compose/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-docker-compose: docker-compose (multi-container orchestration for docker)
+docker-compose: docker-compose (Utility for running containers on Docker)
docker-compose:
-docker-compose: Compose is a tool for defining and running multi-container Docker
-docker-compose: applications. With Compose, you use a Compose file to configure your
-docker-compose: application's services. Then, using a single command, you create and
-docker-compose: start all the services from your configuration.
+docker-compose: Docker Compose is a tool for running multi-container
+docker-compose: applications on Docker defined using the Compose file format. A
+docker-compose: Compose file is used to define how one or more containers that make
+docker-compose: up your application are configured. Once you have a Compose file, you
+docker-compose: can create and start your application with a single command: docker
+docker-compose: compose up.
docker-compose:
docker-compose: Homepage: https://docs.docker.com/compose/
docker-compose:
-docker-compose:
-docker-compose: