summaryrefslogtreecommitdiffstats
path: root/system/borgbackup/borgbackup.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'system/borgbackup/borgbackup.SlackBuild')
-rw-r--r--system/borgbackup/borgbackup.SlackBuild77
1 files changed, 35 insertions, 42 deletions
diff --git a/system/borgbackup/borgbackup.SlackBuild b/system/borgbackup/borgbackup.SlackBuild
index efb0e1bb9a..08fde234df 100644
--- a/system/borgbackup/borgbackup.SlackBuild
+++ b/system/borgbackup/borgbackup.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for borgbackup
-# Copyright 2020 Andrzej Telszewski, Szczecin
+# Copyright 2023 Andrzej Telszewski, Koszalin
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,11 +22,21 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20230809 bkw: Modified by SlackBuilds.org, BUILD=2:
+# - stop the build from failing if Sphinx is installed but
+# guzzle_sphinx_theme is not.
+# - always include man pages in package (upstream kindly included
+# prebuilt ones in the tarball).
+# - clean up optional deps for HTML docs in README. python3-attrs
+# is not required, and alabaster + imagesize are already required
+# deps for Sphinx.
+# - make slack-desc say whether the HTML docs are included.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=borgbackup
-VERSION=${VERSION:-1.1.13}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-1.2.7}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +48,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,61 +57,47 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
+# 20230810 bkw: no flags or libdirsuffix, setup.py knows what to do.
-set -e
+set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
+
rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
+
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+chmod -R a-st,u+rwX,go-w+rX .
python3 setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+# 20230810 bkw: faster than the find|file|xargs template stuff.
+find $PKG/usr/lib*/python* -name '*.so' | xargs strip --strip-unneeded
-if [ -x /usr/bin/sphinx-build ]; then
- cd docs
+PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+mkdir -p $PKGDOC
- make html
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a _build/html $PKG/usr/doc/$PRGNAM-$VERSION
+# 20230809 bkw: stop the build from failing if Sphinx is installed
+# but guzzle_sphinx_theme is not. upstream's README documents this, even.
+make -C docs html && cp -a docs/_build/html $PKGDOC
- make man
- mkdir -p $PKG/usr/man/man1
- cp -a _build/man/*.1 $PKG/usr/man/man1
- gzip -9 $PKG/usr/man/man1/*.1
+# 20230810 bkw: for the slack-desc:
+WITH_HTML=WITHOUT
+[ -d $PKGDOC/html ] && WITH_HTML=WITH
- cd ..
-fi
+# 20230809 bkw: upstream ships prebuilt man pages, always install.
+mkdir -p $PKG/usr/man/man1
+cp -a docs/man/*.1 $PKG/usr/man/man1
+gzip -9 $PKG/usr/man/man1/*
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS CHANGES.rst LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cp -a AUTHORS CHANGES.rst LICENSE README.rst SECURITY.md $PKGDOC
+cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
+sed "s,@WITH_HTML@,$WITH_HTML," < $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE