summaryrefslogtreecommitdiffstats
path: root/system/ansible
diff options
context:
space:
mode:
Diffstat (limited to 'system/ansible')
-rw-r--r--system/ansible/ansible.SlackBuild19
-rw-r--r--system/ansible/ansible.info8
-rw-r--r--system/ansible/doinst.sh15
3 files changed, 7 insertions, 35 deletions
diff --git a/system/ansible/ansible.SlackBuild b/system/ansible/ansible.SlackBuild
index c8b7fe998e..76914fce5c 100644
--- a/system/ansible/ansible.SlackBuild
+++ b/system/ansible/ansible.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2014 Alex Diaconu <alex.diaconu@gmx.com>
# Copyright 2016 Ciorceri Petru Sorin <cpsorin@gmail.com>
-# Copyright 2017-2020 Marek Wodzinski <majek@w7i.pl>
+# Copyright 2017-2024 Marek Wodzinski <majek@w7i.pl>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -27,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=ansible
-VERSION=${VERSION:-2.9.20}
+VERSION=${VERSION:-8.7.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -83,25 +83,12 @@ find -L . \
python3 setup.py install --root=$PKG
-# Copy docs, remove git traces, compress manpages
-cp -a docs/man $PKG/usr/man
-find $PKG/usr/man \
- \( -iname '.git*' \
- -o -iname 'man3' \) -delete # "man3" contains a single ".gitdir" file (yeah)
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/etc/ansible
-cp -a examples/ansible.cfg $PKG/etc/ansible/ansible.cfg.new
-cp -a examples/hosts $PKG/etc/ansible/hosts.new
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a examples COPYING *.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING *.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/system/ansible/ansible.info b/system/ansible/ansible.info
index a04357a7da..aecae39f8c 100644
--- a/system/ansible/ansible.info
+++ b/system/ansible/ansible.info
@@ -1,10 +1,10 @@
PRGNAM="ansible"
-VERSION="2.9.20"
+VERSION="8.7.0"
HOMEPAGE="https://www.ansible.com"
-DOWNLOAD="https://releases.ansible.com/ansible/ansible-2.9.20.tar.gz"
-MD5SUM="47226da137b30883f166d5543882d66f"
+DOWNLOAD="https://files.pythonhosted.org/packages/90/25/55e09468efe564f3b48c47a7e082bd84d4f0d064af60ac8458eba4667994/ansible-8.7.0.tar.gz"
+MD5SUM="7878b20b0994a6740764d6f02dc0f2a5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="cryptography"
+REQUIRES="ansible-core"
MAINTAINER="Marek Wodzinski"
EMAIL="majek@w7i.pl"
diff --git a/system/ansible/doinst.sh b/system/ansible/doinst.sh
deleted file mode 100644
index 52f13dc698..0000000000
--- a/system/ansible/doinst.sh
+++ /dev/null
@@ -1,15 +0,0 @@
-config() {
- NEW="$1"
- OLD="$(dirname $NEW)/$(basename $NEW .new)"
- # If there's no config file by that name, mv it over:
- if [ ! -r $OLD ]; then
- mv $NEW $OLD
- elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
- # toss the redundant copy
- rm $NEW
- fi
- # Otherwise, we leave the .new copy for the admin to consider...
-}
-
-config etc/ansible/ansible.cfg.new
-config etc/ansible/hosts.new