summaryrefslogtreecommitdiffstats
path: root/system/FreeFileSync/use_our_cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'system/FreeFileSync/use_our_cflags.patch')
-rw-r--r--system/FreeFileSync/use_our_cflags.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/system/FreeFileSync/use_our_cflags.patch b/system/FreeFileSync/use_our_cflags.patch
new file mode 100644
index 0000000000..f9de7ee903
--- /dev/null
+++ b/system/FreeFileSync/use_our_cflags.patch
@@ -0,0 +1,14 @@
+diff -Nur orig/Makefile new/Makefile
+--- orig/Makefile 2011-04-19 14:46:30.000000000 -0500
++++ new/Makefile 2011-06-20 12:12:45.252826394 -0500
+@@ -4,8 +4,8 @@
+ SHAREDIR = $(DESTDIR)$(prefix)/share
+ APPSHAREDIR = $(SHAREDIR)/$(APPNAME)
+
+-COMMON_COMPILE_FLAGS = -Wall -pipe `pkg-config --cflags gtk+-2.0` -O3 -pthread -DNDEBUG -DwxUSE_UNICODE -DFFS_LINUX -DTIXML_USE_STL -DWXINTL_NO_GETTEXT_MACRO
+-COMMON_LINK_FLAGS = -O3 -pthread
++COMMON_COMPILE_FLAGS = -Wall -pipe `pkg-config --cflags gtk+-2.0` $(OPTS) -pthread -DNDEBUG -DwxUSE_UNICODE -DFFS_LINUX -DTIXML_USE_STL -DWXINTL_NO_GETTEXT_MACRO
++COMMON_LINK_FLAGS = $(OPTS) -pthread
+
+ #default build
+ FFS_CPPFLAGS = $(COMMON_COMPILE_FLAGS) `wx-config --cxxflags --debug=no --unicode=yes`