summaryrefslogtreecommitdiffstats
path: root/python
diff options
context:
space:
mode:
Diffstat (limited to 'python')
-rw-r--r--python/python-bigfloat/README16
-rw-r--r--python/python-bigfloat/slack-desc19
-rw-r--r--python/python2-bigfloat/README17
-rw-r--r--python/python2-bigfloat/doinst.sh (renamed from python/python-bigfloat/doinst.sh)0
-rw-r--r--python/python2-bigfloat/python2-bigfloat.SlackBuild (renamed from python/python-bigfloat/python-bigfloat.SlackBuild)4
-rw-r--r--python/python2-bigfloat/python2-bigfloat.info (renamed from python/python-bigfloat/python-bigfloat.info)2
-rw-r--r--python/python2-bigfloat/slack-desc19
7 files changed, 39 insertions, 38 deletions
diff --git a/python/python-bigfloat/README b/python/python-bigfloat/README
deleted file mode 100644
index a66784f717..0000000000
--- a/python/python-bigfloat/README
+++ /dev/null
@@ -1,16 +0,0 @@
-The bigfloat module is a Python wrapper for the MPFR library for arbitrary
-precision floating-point reliable arithmetic.
-
-The MPFR library is a well-known portable C library for arbitrary-precision
-arithmetic on floating-point numbers. It provides precise control over
-precisions and rounding modes and gives correctly-rounded reproducible
-platform-independent results.
-
-The bigfloat module aims to provide a convenient and friendly Python
-interface to the operations and functions provided by the MPFR library. The
-main class, BigFloat, gives an immutable multiple-precision floating-point
-type that can be freely mixed with Python integers and floats. The Context
-class, when used in conjunction with Pythons with statement, gives a simple
-way of controlling precisions and rounding modes. Additional module-level
-functions provide various standard mathematical operations. There is full
-support for IEEE 754 signed zeros, nans, infinities and subnormals.
diff --git a/python/python-bigfloat/slack-desc b/python/python-bigfloat/slack-desc
deleted file mode 100644
index 238d503746..0000000000
--- a/python/python-bigfloat/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-python-bigfloat: python-bigfloat (Arbitrary precision floating point arithmetic)
-python-bigfloat:
-python-bigfloat: The bigfloat module is a Python wrapper for the MPFR library for
-python-bigfloat: arbitrary precision floating-point reliable arithmetic.
-python-bigfloat:
-python-bigfloat: The MPFR library is a well-known portable C library for
-python-bigfloat: arbitrary-precision arithmetic on floating-point numbers. It provides
-python-bigfloat: precise control over precisions and rounding modes and gives
-python-bigfloat: correctly-rounded reproducible platform-independent results.
-python-bigfloat:
-python-bigfloat:
diff --git a/python/python2-bigfloat/README b/python/python2-bigfloat/README
new file mode 100644
index 0000000000..88e23f84b2
--- /dev/null
+++ b/python/python2-bigfloat/README
@@ -0,0 +1,17 @@
+The bigfloat module is a Python wrapper for the MPFR library for
+arbitrary precision floating-point reliable arithmetic.
+
+The MPFR library is a well-known portable C library for
+arbitrary-precision arithmetic on floating-point numbers. It provides
+precise control over precisions and rounding modes and gives
+correctly-rounded reproducible platform-independent results.
+
+The bigfloat module aims to provide a convenient and friendly Python
+interface to the operations and functions provided by the MPFR library.
+The main class, BigFloat, gives an immutable multiple-precision
+floating-point type that can be freely mixed with Python integers and
+floats. The Context class, when used in conjunction with Pythons with
+statement, gives a simple way of controlling precisions and rounding
+modes. Additional module-level functions provide various standard
+mathematical operations. There is full support for IEEE 754 signed
+zeros, nans, infinities and subnormals.
diff --git a/python/python-bigfloat/doinst.sh b/python/python2-bigfloat/doinst.sh
index c9ae7e166c..c9ae7e166c 100644
--- a/python/python-bigfloat/doinst.sh
+++ b/python/python2-bigfloat/doinst.sh
diff --git a/python/python-bigfloat/python-bigfloat.SlackBuild b/python/python2-bigfloat/python2-bigfloat.SlackBuild
index 4d6b18334b..e41bde81d4 100644
--- a/python/python-bigfloat/python-bigfloat.SlackBuild
+++ b/python/python2-bigfloat/python2-bigfloat.SlackBuild
@@ -4,7 +4,7 @@
# Written by John Tyree <johntyree@gmail.com>
-PRGNAM=python-bigfloat
+PRGNAM=python2-bigfloat
VERSION=${VERSION:-0.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -54,7 +54,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/python-bigfloat/python-bigfloat.info b/python/python2-bigfloat/python2-bigfloat.info
index c34c5656c4..87ccd69016 100644
--- a/python/python-bigfloat/python-bigfloat.info
+++ b/python/python2-bigfloat/python2-bigfloat.info
@@ -1,4 +1,4 @@
-PRGNAM="python-bigfloat"
+PRGNAM="python2-bigfloat"
VERSION="0.3.0"
HOMEPAGE="https://github.com/mdickinson/bigfloat/"
DOWNLOAD="https://github.com/mdickinson/bigfloat/archive/v0.3.0/bigfloat-0.3.0.tar.gz"
diff --git a/python/python2-bigfloat/slack-desc b/python/python2-bigfloat/slack-desc
new file mode 100644
index 0000000000..fc20de4ea8
--- /dev/null
+++ b/python/python2-bigfloat/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python2-bigfloat: python2-bigfloat (Arbitrary precision floating point arithmetic)
+python2-bigfloat:
+python2-bigfloat: The bigfloat module is a Python wrapper for the MPFR library for
+python2-bigfloat: arbitrary precision floating-point reliable arithmetic.
+python2-bigfloat:
+python2-bigfloat: The MPFR library is a well-known portable C library for
+python2-bigfloat: arbitrary-precision arithmetic on floating-point numbers. It provides
+python2-bigfloat: precise control over precisions and rounding modes and gives
+python2-bigfloat: correctly-rounded reproducible platform-independent results.
+python2-bigfloat:
+python2-bigfloat: