summaryrefslogtreecommitdiffstats
path: root/python/yarl/yarl.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/yarl/yarl.SlackBuild')
-rw-r--r--python/yarl/yarl.SlackBuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/python/yarl/yarl.SlackBuild b/python/yarl/yarl.SlackBuild
index 8d8a4d4dba..f87dbf1ad7 100644
--- a/python/yarl/yarl.SlackBuild
+++ b/python/yarl/yarl.SlackBuild
@@ -1,7 +1,7 @@
-#!/bin/bash
+#!/bin/sh
# Slackware build script for yarl
-# Copyright 2019 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2019-2022 Isaac Yu <isaacyu1@isaacyu1.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=yarl
-VERSION=${VERSION:-1.3.0}
+VERSION=${VERSION:-1.6.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -78,13 +78,17 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Workaround taken from Arch Linux PKGBUILD
+# https://github.com/archlinux/svntogit-community/blob/packages/python-yarl/trunk/PKGBUILD
+sed 's| .install-cython ||g' -i Makefile
+make cythonize
python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a *.rst docs/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst requirements/ LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install