summaryrefslogtreecommitdiffstats
path: root/python/tweepy/tweepy.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/tweepy/tweepy.SlackBuild')
-rw-r--r--python/tweepy/tweepy.SlackBuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/python/tweepy/tweepy.SlackBuild b/python/tweepy/tweepy.SlackBuild
index 10ddbb33d6..217e10b600 100644
--- a/python/tweepy/tweepy.SlackBuild
+++ b/python/tweepy/tweepy.SlackBuild
@@ -1,7 +1,7 @@
#!/bin/sh
# Slackware build script for tweepy
-# Copyright Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy, 2013
+# Copyright 2013-2015 Matteo Bernardini <ponce@slackbuilds.org>, Pisa, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -22,7 +22,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=tweepy
-VERSION=${VERSION:-2.1}
+VERSION=${VERSION:-3.1.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -53,7 +53,10 @@ else
LIBDIRSUFFIX=""
fi
-DOCS="CONTRIBUTORS LICENSE README.md"
+PYTHON=python
+[ "${PYTHON3:-no}" = "yes" ] && PYTHON=python3
+
+DOCS="CHANGELOG.md CONTRIBUTORS LICENSE README.md"
set -e
@@ -61,11 +64,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-if [ -e $CWD/$PRGNAM-$VERSION.tar.?z* ]; then
- tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
-else
- tar xvf $CWD/$VERSION.tar.?z*
-fi
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || tar xvf $CWD/v$VERSION.tar.?z*
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -74,6 +73,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# https://github.com/tweepy/tweepy/issues/533
+patch -p1 < $CWD/update_req_for_pip6.patch
+
+# we have six=1.8.0 and requests-oauthlib=0.4.2, so we cheat
+sed -i -e "s|1\.7\.3|1.8.0|" -e "s|0\.4\.1|0.4.2|" requirements.txt
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \