summaryrefslogtreecommitdiffstats
path: root/python/tqdm/tqdm.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/tqdm/tqdm.SlackBuild')
-rw-r--r--python/tqdm/tqdm.SlackBuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/python/tqdm/tqdm.SlackBuild b/python/tqdm/tqdm.SlackBuild
index 4b63275499..59dd3c1566 100644
--- a/python/tqdm/tqdm.SlackBuild
+++ b/python/tqdm/tqdm.SlackBuild
@@ -23,11 +23,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20231221 46and2: Newer setuptools needed to build properly.
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tqdm
-VERSION=${VERSION:-4.64.0}
-BUILD=${BUILD:-1}
+VERSION=${VERSION:-4.66.1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
if [ -z "$ARCH" ]; then
@@ -73,8 +75,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python setup.py install --root=$PKG
-python3 setup.py install --root=$PKG
+# 46and2: newer setuptools needed
+PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+export PYTHONPATH=/opt/python$PYVER/site-packages/
+
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true