summaryrefslogtreecommitdiffstats
path: root/python/tinycss2
diff options
context:
space:
mode:
Diffstat (limited to 'python/tinycss2')
-rw-r--r--python/tinycss2/tinycss2.SlackBuild27
-rw-r--r--python/tinycss2/tinycss2.info12
2 files changed, 12 insertions, 27 deletions
diff --git a/python/tinycss2/tinycss2.SlackBuild b/python/tinycss2/tinycss2.SlackBuild
index 1d0d4fab9b..6bcbaee6cb 100644
--- a/python/tinycss2/tinycss2.SlackBuild
+++ b/python/tinycss2/tinycss2.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for tinycss2
-# Copyright 2021 Dimitris Zlatanidis Orestiada, Greece
+# Copyright 2021-2024 Dimitris Zlatanidis Orestiada, Greece <d.zlatanidis@gmail.com>
+# Copyright 2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,8 +26,8 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=tinycss2
-VERSION=${VERSION:-1.1.0}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +48,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -79,7 +63,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/tinycss2/tinycss2.info b/python/tinycss2/tinycss2.info
index 8e880b2077..f5c84b8486 100644
--- a/python/tinycss2/tinycss2.info
+++ b/python/tinycss2/tinycss2.info
@@ -1,10 +1,10 @@
PRGNAM="tinycss2"
-VERSION="1.1.0"
+VERSION="1.3.0"
HOMEPAGE="https://www.courtbouillon.org/tinycss2"
-DOWNLOAD="https://files.pythonhosted.org/packages/ce/d3/ece7a98d5826bd134e269a3a3030153d30482194fca71d95a3041812aab8/tinycss2-1.1.0.tar.gz"
-MD5SUM="7caf513c4e87fc2449dcfbf407a8416f"
+DOWNLOAD="https://files.pythonhosted.org/packages/source/t/tinycss2/tinycss2-1.3.0.tar.gz"
+MD5SUM="736b69f1b164da932028538fe2a60262"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="python3-webencodings"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
+REQUIRES="python3-build python3-webencodings"
+MAINTAINER="Isaac Yu"
+EMAIL="isaacyu@protonmail.com"