summaryrefslogtreecommitdiffstats
path: root/python/testpath/testpath.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/testpath/testpath.SlackBuild')
-rw-r--r--python/testpath/testpath.SlackBuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/python/testpath/testpath.SlackBuild b/python/testpath/testpath.SlackBuild
index c75ea3f921..1cdecb92b9 100644
--- a/python/testpath/testpath.SlackBuild
+++ b/python/testpath/testpath.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for testpath
-# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# Copyright 2017-2018 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=testpath
-VERSION=${VERSION:-0.3.1}
+VERSION=${VERSION:-0.4.1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,7 +70,8 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cp $CWD/setup.py .
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
+python3 setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true