summaryrefslogtreecommitdiffstats
path: root/python/terminado/terminado.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/terminado/terminado.SlackBuild')
-rw-r--r--python/terminado/terminado.SlackBuild28
1 files changed, 5 insertions, 23 deletions
diff --git a/python/terminado/terminado.SlackBuild b/python/terminado/terminado.SlackBuild
index 37eacb5f5a..9f5c3b1580 100644
--- a/python/terminado/terminado.SlackBuild
+++ b/python/terminado/terminado.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for terminado
# Copyright 2017-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022-2024 Isaac Yu <isaacyu@protonmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +26,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=terminado
-VERSION=${VERSION:-0.15.0}
+VERSION=${VERSION:-0.18.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +39,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -80,29 +77,14 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-# Use this setup.py shim:
-cat << EOF > setup.py
-from setuptools import setup, find_packages
-setup(name='${PRGNAM}',
- version='${VERSION}',
- packages=find_packages(),
- package_data={'': ['*'], 'terminado': ['_static/*']},
- install_requires=["ptyprocess;os_name!='nt'", "pywinpty>=1.1.0;os_name=='nt'", "tornado>=6.1.0"],
- extras_require={'test': ['pytest']},
-)
-EOF
-
-# With the shim, it's a good idea to use "unshare -n" to prevent downloading
-# anything extra:
-unshare -n python3 setup.py install --root=$PKG || exit 1
+python3 -m build --no-isolation
+python3 -m installer -d "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- LICENSE PKG-INFO README.rst \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md CONTRIBUTING.rst LICENSE README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install