summaryrefslogtreecommitdiffstats
path: root/python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild')
-rw-r--r--python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild25
1 files changed, 4 insertions, 21 deletions
diff --git a/python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild b/python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild
index 3766336c21..587c0bef6f 100644
--- a/python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild
+++ b/python/sphinx-last-updated-by-git/sphinx-last-updated-by-git.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for sphinx-last-updated-by-git
-# Copyright 2022 Vijay Marcel
+# Copyright 2022-2023 Vijay Marcel
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -25,7 +25,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=sphinx-last-updated-by-git
-VERSION=${VERSION:-0.3.4}
+VERSION=${VERSION:-0.3.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -38,9 +38,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -50,20 +47,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
trap 'echo "$0 FAILED at line $LINENO!" | tee -a $OUTPUT/error-${PRGNAM}.log' ERR
@@ -85,10 +68,10 @@ python3 setup.py install --prefix=/usr --root=$PKG --optimize=1
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE NEWS.rst PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE NEWS.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 0644 {} \+
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc