summaryrefslogtreecommitdiffstats
path: root/python/sge-pygame
diff options
context:
space:
mode:
Diffstat (limited to 'python/sge-pygame')
-rw-r--r--python/sge-pygame/README5
-rw-r--r--python/sge-pygame/sge-pygame.SlackBuild97
-rw-r--r--python/sge-pygame/sge-pygame.info10
-rw-r--r--python/sge-pygame/slack-desc19
4 files changed, 0 insertions, 131 deletions
diff --git a/python/sge-pygame/README b/python/sge-pygame/README
deleted file mode 100644
index 8e6508cee4..0000000000
--- a/python/sge-pygame/README
+++ /dev/null
@@ -1,5 +0,0 @@
-The Stellar Game Engine (abbreviated "SGE", pronounced as "Sage")
-is a free 2-D game engine. The purpose of the SGE is to make game
-development easier, which allows more rapid development by
-experienced game developers and also helps less experienced game
-developers learn how to develop games.
diff --git a/python/sge-pygame/sge-pygame.SlackBuild b/python/sge-pygame/sge-pygame.SlackBuild
deleted file mode 100644
index e0459584ba..0000000000
--- a/python/sge-pygame/sge-pygame.SlackBuild
+++ /dev/null
@@ -1,97 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for sge-pygame
-
-# Copyright 2014-2022 Dimitris Zlatanidis Orestiada, Greece
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=sge-pygame
-VERSION=${VERSION:-2.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-SRCNAM=sge
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python3 setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README WHATSNEW* VERSION* $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/sge-pygame/sge-pygame.info b/python/sge-pygame/sge-pygame.info
deleted file mode 100644
index 340a941218..0000000000
--- a/python/sge-pygame/sge-pygame.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="sge-pygame"
-VERSION="2.0"
-HOMEPAGE="https://python-sge.github.io/"
-DOWNLOAD="https://files.pythonhosted.org/packages/6f/6a/125126fa4231f215fd932bcdea83a8a0262dfe54c91d864ecbdcde7820d9/sge-2.0.tar.gz"
-MD5SUM="39054614a9526678c948917f5d2c8fad"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pygame"
-MAINTAINER="Dimitris Zlatanidis"
-EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/sge-pygame/slack-desc b/python/sge-pygame/slack-desc
deleted file mode 100644
index 77769d141b..0000000000
--- a/python/sge-pygame/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-sge-pygame: sge-pygame (Game Engine)
-sge-pygame:
-sge-pygame: The Stellar Game Engine (abbreviated "SGE",
-sge-pygame: pronounced as "Sage") is a free 2-D game engine.
-sge-pygame:
-sge-pygame: Homepage: https://python-sge.github.io/
-sge-pygame:
-sge-pygame:
-sge-pygame:
-sge-pygame:
-sge-pygame: