summaryrefslogtreecommitdiffstats
path: root/python/send2trash
diff options
context:
space:
mode:
Diffstat (limited to 'python/send2trash')
-rw-r--r--python/send2trash/send2trash.SlackBuild25
-rw-r--r--python/send2trash/send2trash.info12
2 files changed, 11 insertions, 26 deletions
diff --git a/python/send2trash/send2trash.SlackBuild b/python/send2trash/send2trash.SlackBuild
index 90bc62870b..6b827c34a3 100644
--- a/python/send2trash/send2trash.SlackBuild
+++ b/python/send2trash/send2trash.SlackBuild
@@ -3,7 +3,8 @@
# Slackware build script for send2trash
# Copyright 2018-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# Copyright 2022 Isaac Yu <isaacyu1@isaacyu1.com>
+# Copyright 2022 Isaac Yu <isaacyu@protonmail.com>
+# Copyright 2023 Jeremy Hansen <jebrhansen+SBo@gmail.com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -26,7 +27,7 @@
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=send2trash
-VERSION=${VERSION:-1.8.0}
+VERSION=${VERSION:-1.8.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
@@ -39,9 +40,6 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -51,20 +49,6 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
set -e
rm -rf $PKG
@@ -80,7 +64,8 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-python3 setup.py install --root=$PKG
+python3 -m build --wheel --no-isolation
+python3 -m installer --destdir "$PKG" dist/*.whl
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
diff --git a/python/send2trash/send2trash.info b/python/send2trash/send2trash.info
index e26e7be2cc..cf9cf79083 100644
--- a/python/send2trash/send2trash.info
+++ b/python/send2trash/send2trash.info
@@ -1,10 +1,10 @@
PRGNAM="send2trash"
-VERSION="1.8.0"
+VERSION="1.8.2"
HOMEPAGE="https://github.com/hsoft/send2trash"
-DOWNLOAD="https://github.com/hsoft/send2trash/archive/1.8.0/send2trash-1.8.0.tar.gz"
-MD5SUM="4bbf941d555bb95836ce273d777256d0"
+DOWNLOAD="https://github.com/hsoft/send2trash/archive/1.8.2/send2trash-1.8.2.tar.gz"
+MD5SUM="eb438133a06589d66fd0b9d401d4bbc5"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Isaac Yu"
-EMAIL="isaacyu1@isaacyu1.com"
+REQUIRES="python3-build python3-wheel"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo@gmail.com"