summaryrefslogtreecommitdiffstats
path: root/python/s3cmd/s3cmd.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/s3cmd/s3cmd.SlackBuild')
-rw-r--r--python/s3cmd/s3cmd.SlackBuild30
1 files changed, 24 insertions, 6 deletions
diff --git a/python/s3cmd/s3cmd.SlackBuild b/python/s3cmd/s3cmd.SlackBuild
index c800b34eae..90a6e7ab06 100644
--- a/python/s3cmd/s3cmd.SlackBuild
+++ b/python/s3cmd/s3cmd.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for s3cmd
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2011-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=s3cmd
-VERSION=${VERSION:-1.5.0_beta1}
+VERSION=${VERSION:-1.5.0_rc1}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -32,10 +50,10 @@ tar xvf $CWD/$PRGNAM-${VERSION/_/-}.tar.gz
cd $PRGNAM-${VERSION/_/-}
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
sed -i 's|\(doc_path\)+"/s3cmd"|\1|' setup.py