summaryrefslogtreecommitdiffstats
path: root/python/rst-linker/rst-linker.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/rst-linker/rst-linker.SlackBuild')
-rw-r--r--python/rst-linker/rst-linker.SlackBuild11
1 files changed, 4 insertions, 7 deletions
diff --git a/python/rst-linker/rst-linker.SlackBuild b/python/rst-linker/rst-linker.SlackBuild
index 1059e69ef2..b0d3bee99b 100644
--- a/python/rst-linker/rst-linker.SlackBuild
+++ b/python/rst-linker/rst-linker.SlackBuild
@@ -41,15 +41,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -64,11 +61,11 @@ cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} \+ -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
-python setup.py install --root=$PKG
+python2 setup.py install --root=$PKG
python3 setup.py install --root=$PKG
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION