summaryrefslogtreecommitdiffstats
path: root/python/rsa
diff options
context:
space:
mode:
Diffstat (limited to 'python/rsa')
-rw-r--r--python/rsa/README5
-rw-r--r--python/rsa/rsa.SlackBuild78
-rw-r--r--python/rsa/rsa.info10
-rw-r--r--python/rsa/slack-desc19
4 files changed, 0 insertions, 112 deletions
diff --git a/python/rsa/README b/python/rsa/README
deleted file mode 100644
index 5311a7072d..0000000000
--- a/python/rsa/README
+++ /dev/null
@@ -1,5 +0,0 @@
-Python-RSA is a pure-Python RSA implementation. It supports encryption
-and decryption, signing and verifying signatures, and key generation
-according to PKCS#1 version 1.5.
-
-Optional dependencies: psyco
diff --git a/python/rsa/rsa.SlackBuild b/python/rsa/rsa.SlackBuild
deleted file mode 100644
index 662b21ae67..0000000000
--- a/python/rsa/rsa.SlackBuild
+++ /dev/null
@@ -1,78 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for rsa
-
-# Copyright 2013-2018 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=rsa
-VERSION=${VERSION:-4.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python2 setup.py install --root=$PKG
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/python/rsa/rsa.info b/python/rsa/rsa.info
deleted file mode 100644
index 48e7def0b3..0000000000
--- a/python/rsa/rsa.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="rsa"
-VERSION="4.0"
-HOMEPAGE="https://stuvel.eu/rsa"
-DOWNLOAD="https://pypi.python.org/packages/source/r/rsa/rsa-4.0.tar.gz"
-MD5SUM="9f9af433a16868b616fc609215e91ddb"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pyasn1"
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/python/rsa/slack-desc b/python/rsa/slack-desc
deleted file mode 100644
index c12bfdd3b0..0000000000
--- a/python/rsa/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-rsa: rsa (Pure-Python RSA implementation)
-rsa:
-rsa: Python-RSA is a pure-Python RSA implementation. It supports encryption
-rsa: and decryption, signing and verifying signatures, and key generation
-rsa: according to PKCS#1 version 1.5.
-rsa:
-rsa: Homepage: https://stuvel.eu/rsa
-rsa:
-rsa:
-rsa:
-rsa: