summaryrefslogtreecommitdiffstats
path: root/python/reedsolo/reedsolo.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/reedsolo/reedsolo.SlackBuild')
-rw-r--r--python/reedsolo/reedsolo.SlackBuild22
1 files changed, 7 insertions, 15 deletions
diff --git a/python/reedsolo/reedsolo.SlackBuild b/python/reedsolo/reedsolo.SlackBuild
index 76669f0959..36ed54f104 100644
--- a/python/reedsolo/reedsolo.SlackBuild
+++ b/python/reedsolo/reedsolo.SlackBuild
@@ -38,15 +38,12 @@ if [ -z "$ARCH" ]; then
esac
fi
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
fi
-TMP=${TMP:-/tmp}
+TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
@@ -67,18 +64,13 @@ find -L . \
rm -f creedsolo.c
-# Python 2.7 will be droped in the future.
-if $(python2 -c 'import sys' 2>/dev/null); then
- python2 setup.py install --root=$PKG
-else
- python setup.py install --root=$PKG
-fi
+# Python 2.7 will be dropped in the future.
+python2 setup.py install --root=$PKG
-# Replacement of python-2.x Python3.x check presence and build if found.
-if $(python3 -c 'import sys' 2>/dev/null); then
- rm -f creedsolo.c
- python3 setup.py install --root=$PKG
-fi
+rm -f creedsolo.c
+python3 setup.py install --root=$PKG
+
+strip $PKG/usr/lib*/python*/site-packages/*.so
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION