summaryrefslogtreecommitdiffstats
path: root/python/pyxdg/pyxdg.SlackBuild
diff options
context:
space:
mode:
Diffstat (limited to 'python/pyxdg/pyxdg.SlackBuild')
-rw-r--r--python/pyxdg/pyxdg.SlackBuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/python/pyxdg/pyxdg.SlackBuild b/python/pyxdg/pyxdg.SlackBuild
index 07d51b256b..a1e16ec70d 100644
--- a/python/pyxdg/pyxdg.SlackBuild
+++ b/python/pyxdg/pyxdg.SlackBuild
@@ -23,16 +23,14 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pyxdg
-VERSION=${VERSION:-0.18}
+VERSION=${VERSION:-0.25}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -65,11 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root $PKG